smartPi

Anfragen zum Erstellen von Modulen, Fragen zu Modulen
Antworten
zimberg44
Beiträge: 121
Registriert: Do Aug 15, 2019 10:57 am

smartPi

Beitrag von zimberg44 » Fr Aug 16, 2019 6:04 am

Hallo alle

Ein Modul für den smartPi wäre schön. Ev. geht es auch mit dem bestehenden JSON-Modul.

Beiliegend was die Abfrage des API *http://smartpi.home:1080/api/all/all/now" ergibt. Irgendwie muss das geparst und Werte zu den drei Phasen zusammengeführt werden.

Könnte ein bestehendes Modul ev. mit kleinen Abänderungen verwendet werden?

Grüsse

Zimberg44
Dateianhänge
20180816_smartPi-JSON-Abfrage.txt
(2.22 KiB) 91-mal heruntergeladen
openWB Charge Controller Ver. 1.8.201ightly auf Pi 4 (buster) - go-eCharger Ver. 033 - WR: Fronius Symo - EVU: smartPi - Renault Zoe Q210 Intens 2015 mit neuem Ladegerät (lädt ab 7A einphasig)

zimberg44
Beiträge: 121
Registriert: Do Aug 15, 2019 10:57 am

Re: smartPi

Beitrag von zimberg44 » So Feb 16, 2020 9:20 am

Habe es soeben geschafft, den smartPi via Node-Red auf dem smartPi (ist ohnehin vorinstalliert) mit dem openWB Charge Controller zu verbinden.

Aber Achtung, im Widerspruch zu den Angaben unter "Einstellungen" "Strombezugsmessmodul" "MQTT" muss "set" teilweise weggelassen werden:
  • Bei openWB/set/evu/W musste ich das "set" weglassen
  • Bei openWB/set/evu/APhase1|2|3 durfte das "set" nicht weggelassen werden
Weiter finde ich die MQTT-Topic nicht, um bspw. auch Spannung V und Leistung W je Phase auf dem openWB Charge Controller zu setzen. Weiss jemand wie?
openWB Charge Controller Ver. 1.8.201ightly auf Pi 4 (buster) - go-eCharger Ver. 033 - WR: Fronius Symo - EVU: smartPi - Renault Zoe Q210 Intens 2015 mit neuem Ladegerät (lädt ab 7A einphasig)

openWBSupport
Site Admin
Beiträge: 3346
Registriert: So Okt 07, 2018 1:50 pm

Re: smartPi

Beitrag von openWBSupport » So Feb 16, 2020 10:28 am

Das set darf nicht weggelassen werden.
Sonst wird es nicht richtig funktionieren.
Ein gültiger Wert muss natürlich gesendet werden, sonst wird dieser nicht angenommen.
Supportanfragen bitte NICHT per PN stellen.
Hardwareprobleme bitte über die Funktion Debug Daten senden mitteilen oder per Mail an support@openwb.de

zimberg44
Beiträge: 121
Registriert: Do Aug 15, 2019 10:57 am

Re: smartPi

Beitrag von zimberg44 » So Feb 16, 2020 10:46 am

Fakt ist:
  • Wenn ich das "set" weglasse, wird unter Einspeisung etwa im Sekundentakt der korrekte Wert angezeigt; also gehe ich von einem gültigen Wert aus. Der Hausverbrauch entspricht dann aber der PV-Leistung, statt der einschlägigen Differenz.
  • Wenn ich es nicht weglasse, bleibt der letzte Wert unter Einspeisung eingefroren
Ev. stört man sich in der einen Varianten an den Nachkommastellen, in der anderen Variante dann nicht.
openWB Charge Controller Ver. 1.8.201ightly auf Pi 4 (buster) - go-eCharger Ver. 033 - WR: Fronius Symo - EVU: smartPi - Renault Zoe Q210 Intens 2015 mit neuem Ladegerät (lädt ab 7A einphasig)

openWBSupport
Site Admin
Beiträge: 3346
Registriert: So Okt 07, 2018 1:50 pm

Re: smartPi

Beitrag von openWBSupport » So Feb 16, 2020 11:48 am

ohne set siehst du es nur im interface, die regelung im hintergrund bekommt davon aber nichts mit.
heißt das geht so nicht.

ggf mal neustarten, es muss mit set übermittelt werden.

Wie sieht denn ein Beispielwert aus den du übermittelst?
Supportanfragen bitte NICHT per PN stellen.
Hardwareprobleme bitte über die Funktion Debug Daten senden mitteilen oder per Mail an support@openwb.de

zimberg44
Beiträge: 121
Registriert: Do Aug 15, 2019 10:57 am

Re: smartPi

Beitrag von zimberg44 » So Feb 16, 2020 12:06 pm

Neustart hat nichts gebracht.

Der MQTT-Broker hat den richtigen (set-) Wert (mit 2 Kommastellen) und sowohl "WHouseConsumption" und "W" (letzteres mit umgekehrtem Vorzeichen) zeigen die PV-Wert an (ich lade momentan mein EV nicht), aber unter "Einspeisung" steht (nach dem Neustart) stets 0.
openWB Charge Controller Ver. 1.8.201ightly auf Pi 4 (buster) - go-eCharger Ver. 033 - WR: Fronius Symo - EVU: smartPi - Renault Zoe Q210 Intens 2015 mit neuem Ladegerät (lädt ab 7A einphasig)

openWBSupport
Site Admin
Beiträge: 3346
Registriert: So Okt 07, 2018 1:50 pm

Re: smartPi

Beitrag von openWBSupport » So Feb 16, 2020 12:29 pm

es darf nur int übergeben werden, steht auch dabei. daher wird’s verworfen...
Supportanfragen bitte NICHT per PN stellen.
Hardwareprobleme bitte über die Funktion Debug Daten senden mitteilen oder per Mail an support@openwb.de

zimberg44
Beiträge: 121
Registriert: Do Aug 15, 2019 10:57 am

Re: smartPi

Beitrag von zimberg44 » So Feb 16, 2020 1:05 pm

Es wäre schön, wenn das seitens openWB auf int ge-cast-et würde.
openWB Charge Controller Ver. 1.8.201ightly auf Pi 4 (buster) - go-eCharger Ver. 033 - WR: Fronius Symo - EVU: smartPi - Renault Zoe Q210 Intens 2015 mit neuem Ladegerät (lädt ab 7A einphasig)

zimberg44
Beiträge: 121
Registriert: Do Aug 15, 2019 10:57 am

Re: smartPi

Beitrag von zimberg44 » So Feb 16, 2020 2:57 pm

cast im Node-RED:

msg.payload = parseInt(msg.payload,10);
return msg;

Und es funzt!
openWB Charge Controller Ver. 1.8.201ightly auf Pi 4 (buster) - go-eCharger Ver. 033 - WR: Fronius Symo - EVU: smartPi - Renault Zoe Q210 Intens 2015 mit neuem Ladegerät (lädt ab 7A einphasig)

Antworten