Themes

Fragen zur Nutzung, Features, usw..
LocutusB
Beiträge: 104
Registriert: So Dez 02, 2018 2:12 pm

Themes

Beitrag von LocutusB » Mi Jun 12, 2019 10:31 am

Möchte hier mal ein Thread aufmachen, der sich speziell mit den Themes beschäftigt. Finde die Idee super und auch die Umsetzung ist schon recht gelungen. Dennoch habe ich eine Frage dazu.
Inzwischen wird die Auswahl des jeweiligen Themes ja über die Einstellungen vorgenommen und dann an dem jeweiligen Rechner/Browser in einem Cockie gespeichert. Gibt es eine Möglichkeit, ein Theme vorzugeben, ohne direkten Zugriff auf den Browser/PC zu haben (Raspberry Display)? Vorher gab es ja einen Direktlink, den es jetzt nicht mehr gibt.
Konfiguration: OpenWB auf Raspberry Pi 3 B+ an EVSE DIN ModBus, SDM120, 1-phasig max 20A, festes Kabel. BMW i3.

snaptec
Site Admin
Beiträge: 858
Registriert: So Okt 07, 2018 1:50 pm

Re: Themes

Beitrag von snaptec » Mi Jun 12, 2019 10:39 am

Das müsstest du einmal händisch setzen.
Das kannst du an dem Browser auch ohne die Einstellungen machen:
z.B.

Code: Alles auswählen

http://IPDEROPENWB/openWB/web/setThemeCookie.php?theme=standard

LocutusB
Beiträge: 104
Registriert: So Dez 02, 2018 2:12 pm

Re: Themes

Beitrag von LocutusB » Mi Jun 12, 2019 10:46 am

Danke, wird getestet :-). Falls sich noch jemand an ein Wallbox-Display machen möchte, das Öffnen der Website auf dem RPi habe ich nach dieser Anleitung umgesetzt. Dort wird dann ein sehr reduziertes Theme laufen. Das ganze ist natürlich nicht auf die WB beschränkt, sondern könnte mit einen Touch-Display z.B. auch in einem kleinen Rahmen am "Schlüsselbrett" verwendet werden. Hier eröffnen die Themes ganz neue Möglichkeiten. Vielen Dank dafür :-).
Konfiguration: OpenWB auf Raspberry Pi 3 B+ an EVSE DIN ModBus, SDM120, 1-phasig max 20A, festes Kabel. BMW i3.

RosenZOE
Beiträge: 25
Registriert: Do Mär 14, 2019 11:27 am

Re: Themes

Beitrag von RosenZOE » Do Jun 13, 2019 6:45 pm

Bei dem Theme mobile_gauges_1 ändert sich die Hintergrundfarbe bei mir auf weiß, wenn ich auf "Sofort Laden" klicke.
Dann ist die Schrift nicht mehr gut zu lesen.
Hat das etwas mit den zusätzlichen Optionen zu tun, die dann erscheinen?
Möglicher Hinweis: Ich habe nur einen Ladepunkt aktiviert.

snaptec
Site Admin
Beiträge: 858
Registriert: So Okt 07, 2018 1:50 pm

Re: Themes

Beitrag von snaptec » Do Jun 13, 2019 7:05 pm

In welcher OpenWB Version?

RosenZOE
Beiträge: 25
Registriert: Do Mär 14, 2019 11:27 am

Re: Themes

Beitrag von RosenZOE » Fr Jun 14, 2019 5:03 am

Habe die 1.52 Beta drauf. Der Effekt ist mir aber schon vorher aufgefallen, eigentlich seit es dieses Theme gibt.
Bisher nur mit Chrome unter Android getestet. Ich werde es später mal am PC versuchen.

snaptec
Site Admin
Beiträge: 858
Registriert: So Okt 07, 2018 1:50 pm

Re: Themes

Beitrag von snaptec » Fr Jun 14, 2019 5:38 am

Hast du mal einen Screenshot?
Weiß nicht so recht was du meinst.

RosenZOE
Beiträge: 25
Registriert: Do Mär 14, 2019 11:27 am

Re: Themes

Beitrag von RosenZOE » Fr Jun 14, 2019 7:51 am

Hier der dunkle Hintergrund :
20190614_090138.jpg
20190614_090138.jpg (454.02 KiB) 375 mal betrachtet
Und hier nach dem Umschalten auf "Sofort Laden" :
20190614_094400.jpg
20190614_094400.jpg (374.71 KiB) 375 mal betrachtet
Hier die Optionen, die weiter unten stehen. Dort sieht man dann weiße Schrift auf weißen Hintergrund:
Screenshot_20190614-094923_Chrome.jpg
Screenshot_20190614-094923_Chrome.jpg (103.58 KiB) 375 mal betrachtet

aiole
Beiträge: 366
Registriert: Mo Okt 08, 2018 4:51 pm

Re: Themes

Beitrag von aiole » Sa Jul 13, 2019 10:19 pm

RosenZOE hat geschrieben:
Do Jun 13, 2019 6:45 pm
Bei dem Theme mobile_gauges_1 ändert sich die Hintergrundfarbe bei mir auf weiß, wenn ich auf "Sofort Laden" klicke.
Dann ist die Schrift nicht mehr gut zu lesen.
Hat das etwas mit den zusätzlichen Optionen zu tun, die dann erscheinen?
Möglicher Hinweis: Ich habe nur einen Ladepunkt aktiviert.
sehr komisch. Ich habe das plötzlich auch festgestellt (v1.55a, v1.56a jeweils beta) - allerdings alle 3 LP aktiv.
Bei Sofortladen sind die Auswahlfelder plötzlich weiß.

Firefox auf Android-tablet
VG aiole

snaptec
Site Admin
Beiträge: 858
Registriert: So Okt 07, 2018 1:50 pm

Re: Themes

Beitrag von snaptec » Sa Jul 13, 2019 10:32 pm

Kann ich leider so nicht nachstellen, mal den Browser Cache geleert bzw. den "privaten Modus" genutzt?

Antworten