Support: Mercedes EQ

Alles rund um SoC (Ladezustand des Fahrzeuges). Probleme, Fragen, Fehlfunktionen gehören hier hin
CLu
Beiträge: 3
Registriert: Do Okt 21, 2021 6:45 am

Re: Support: Mercedes EQ

Beitrag von CLu »

Danke für die schnelle Antwort.

Und ja, selbst (auf RasPi) installiert. Der Tipp mit der Nightly hat geholfen, die habe ich nun drüberinstalliert und es sieht gut aus.
Range kommt (Wert ist aber falsch), SoC noch nicht

2021-10-21 11:31:26: Lp1: PID:4159: SOC: 0 RANGE: 270
2021-10-21 11:31:26: Lp1: PID:4159: SoC Value not filled [{"rangeelectric":{"value":"270","timestamp":1634285752000}}]
2021-10-21 11:31:26: Lp1: PID:4159: SOC Response: [{"rangeelectric":{"value":"270","timestamp":1634285752000}}]

Aber ich warte nun erstmal ab, bis das Auto etwas bewegt wurde - zumindest scheint die API-Abfrage jetzt zu gehen.

Ich melde mich, wenn ich damit nicht weiterkomme. Danke nochmals.
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

Ja, das Thema gab es schon mal. Einfach fahren, dann kommt der Wert auch.
API Zugriff funktioniert, Range kommt ja schon was.


VG
Det
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
CLu
Beiträge: 3
Registriert: Do Okt 21, 2021 6:45 am

Re: Support: Mercedes EQ

Beitrag von CLu »

Genauso war's - jetzt sind die Werte da!
coo2sh
Beiträge: 3
Registriert: Mi Okt 27, 2021 8:58 am

Re: Support: Mercedes EQ

Beitrag von coo2sh »

Hallo zusammen,
Ich habe gestern das SOC Module für Mercedes EQ aktiviert.
Alles hat prima funktioniert. Anleitung in Wiki war sehr hilfreich.
Mein series2+ zeigt jetzt mein GLE-SOC.
Vielen Dank an den developers & Doku-macher...
VG Ol
11kWp | RCT Power Inverter + Batterie 11kWh | OpenWB series2 standard+ | GLE 350de
shesse
Beiträge: 104
Registriert: Di Jun 23, 2020 12:21 pm
Wohnort: Schleswig-Holstein

Re: Support: Mercedes EQ

Beitrag von shesse »

Seit ca. 2 Tagen ist die Abfrage bei mir nur sehr unzuverlässig. Zwischendurch funktioniert es mal wieder und dann wieder einige Stunden nicht. Somit würde ich eigentlich eine Fehlkonfiguration ausschließen:

[quote]
{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-30 02:11:06: Lp2: PID:13229:
2021-10-30 02:11:06: Lp2: PID:13229: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-30 01:10:56: Lp2: PID:26171:
2021-10-30 01:10:56: Lp2: PID:26171: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-30 00:10:46: Lp2: PID:6869:
2021-10-30 00:10:46: Lp2: PID:6869: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 23:10:36: Lp2: PID:19808:
2021-10-29 23:10:36: Lp2: PID:19808: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 22:10:26: Lp2: PID:361:
2021-10-29 22:10:26: Lp2: PID:361: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 21:10:16: Lp2: PID:12656:
2021-10-29 21:10:16: Lp2: PID:12656: SoC Request fehlgeschlagen Code: 403 (Forbidden)
2021-10-29 21:05:05: Lp2: PID:6906: SOC: 95 RANGE: 34

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 20:59:55: Lp2: PID:841:
2021-10-29 20:59:55: Lp2: PID:841: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 20:54:46: Lp2: PID:27583:
2021-10-29 20:54:46: Lp2: PID:27583: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 20:49:35: Lp2: PID:21901:
2021-10-29 20:49:35: Lp2: PID:21901: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 20:44:26: Lp2: PID:16223:
2021-10-29 20:44:26: Lp2: PID:16223: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 20:39:15: Lp2: PID:10502:
2021-10-29 20:39:15: Lp2: PID:10502: SoC Request fehlgeschlagen Code: 403 (Forbidden)

{"errorMessage": "Forbidden", "statusCode": "403"}
2021-10-29 20:34:05: Lp2: PID:4753:
2021-10-29 20:34:05: Lp2: PID:4753: SoC Request fehlgeschlagen Code: 403 (Forbidden)
[/quote]

Hat das noch jemand?

Gruß,
Stefan
Benutzeravatar
ragsna
Beiträge: 123
Registriert: Mi Nov 04, 2020 5:00 pm

Re: Support: Mercedes EQ

Beitrag von ragsna »

Ja, ist bei mir auch so. War mir allerdings noch nicht aufgefallen. :?
openWB series2 custom - SolarEdge | 9.92 kWp | 2 x SE5000H | LG Resu10H 9.3 kWh - MB EQA 250
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

Liegt am Backend bei Mercedes. Ich mache mal ne Meldung auf im Developer Portal
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
moggmogg
Beiträge: 31
Registriert: Di Apr 21, 2020 9:59 am

Re: Support: Mercedes EQ

Beitrag von moggmogg »

Ich habe das Problem derzeit auch. Seit gestern tut sich nix mehr. Bekomme auch 403 zurück.

Nächstes Problem: Am kommenden Do wird der B250e Plug In durch einen EQA ersetzt. Muss ich da jetzt im Developer Portal alles löschen und neu einrichten gemäß Wiki oder reicht es da irgendwo die FIN neu einzutragen :?:
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

Ich bin gerade im Urlaub, aber meine Box zeigt noch immer wieder mal SoC Werte zwischen den 403 Fehlern.
Vom Developer Portal hab ich noch nichts gehört, außer dass die Meldung aufgenommen wurde.
Aber letztes Mal war es auch so, dass die Meldungen weg waren und ich dann erst einen Tag später die Bestätigung bekommen habe, dass es behoben wurde.

Zu der EQA Frage: ich denke es sollte reichen, die Fin (VIN) zu ändern.

Da hast du ja Glück mit dem EQA. Meiner hätte im Oktober kommen sollen. Aktuell heißt es "evtl. Q1.2022"

VG
Det
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

Kam doch ne Antwort, sie kümmern sich drum.
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
Antworten