Hyundai Bluelink wieder kein SoC???

Fragen zur Nutzung, Features, usw..
derNeueDet
Beiträge: 645
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von derNeueDet »

Unter Status und dann auf EV SoC Log
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
gorthon
Beiträge: 139
Registriert: So Okt 04, 2020 4:33 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von gorthon »

Gehst du auf Status und dann ganz unten das letzte Log anklicken.
FaKaBeFr
Beiträge: 17
Registriert: Mo Nov 09, 2020 11:09 am

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von FaKaBeFr »

Bei mir hatte es einen Tag funktioniert. Seitdem wieder Fehler 400
Installiert ist die neuste Nightly Version
StubbeA
Beiträge: 141
Registriert: Mo Sep 07, 2020 5:23 am
Wohnort: SZ/WF/HARZ

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von StubbeA »

Hast Du mal Dein Passwort über die App geändert u d dann wieder probiert.
Ich hatte das im März. Passwort-Änderung war wohl erforderlich...
gorthon
Beiträge: 139
Registriert: So Okt 04, 2020 4:33 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von gorthon »

Nachdem ich heute eine leere 12V-Batterie hatte, obwohl ich gestern morgen noch gefahren bin und gestern Mittag 9 kWh geladen habe, habe ich mir nochmal das SoC-Log angeschaut. Mein Abfrageintervall ist auf 120 Minuten eingestellt:

Code: Alles auswählen

2021-04-29 13:35:33: LP1:             Connection Timeout (To Car)
2021-04-29 13:33:31: LP1:             Connection Timeout (To Car)
2021-04-29 13:32:28: LP1:         SoC download starting
2021-04-29 13:25:33: LP1:             Receiving status failed, StatusCode: 400
2021-04-29 13:24:31: LP1:             Connection Timeout (To Car)
2021-04-29 13:23:28: LP1:         SoC download starting
2021-04-29 13:17:32: LP1:             Connection Timeout (To Car)
2021-04-29 13:15:30: LP1:             Connection Timeout (To Car)
2021-04-29 13:14:28: LP1:         SoC download starting
2021-04-29 13:14:14: LP1:             Receiving status failed, StatusCode: 400
2021-04-29 13:13:11: LP1:             Connection Timeout (To Car)
2021-04-29 13:12:09: LP1:         SoC download starting
2021-04-29 12:20:13: LP1:             Connection Timeout (To Car)
2021-04-29 12:18:11: LP1:             Connection Timeout (To Car)
2021-04-29 12:17:08: LP1:         SoC download starting
2021-04-29 12:11:03: LP1:             Connection Timeout (To Car)
2021-04-29 12:09:01: LP1:             Connection Timeout (To Car)
2021-04-29 12:07:58: LP1:         SoC download starting
2021-04-29 11:06:01: LP1:             Receiving status failed, StatusCode: 400
2021-04-29 11:05:58: LP1:         SoC download starting
2021-04-29 10:56:12: LP1:             Connection Timeout (To Car)
2021-04-29 10:54:10: LP1:             Connection Timeout (To Car)
2021-04-29 10:53:08: LP1:         SoC download starting
2021-04-29 10:47:33: LP1:             Connection Timeout (To Car)
2021-04-29 10:45:31: LP1:             Connection Timeout (To Car)
2021-04-29 10:44:29: LP1:         SoC download starting
2021-04-29 10:33:03: LP1:             Connection Timeout (To Car)
2021-04-29 10:31:01: LP1:             Connection Timeout (To Car)
2021-04-29 10:29:58: LP1:         SoC download starting
2021-04-29 10:28:11: LP1:             Receiving status failed, StatusCode: 400
2021-04-29 10:28:08: LP1:         SoC download starting
2021-04-29 10:27:53: LP1:             Receiving status failed, StatusCode: 400
2021-04-29 10:26:51: LP1:             Connection Timeout (To Car)
2021-04-29 10:25:49: LP1:         SoC download starting
2021-04-29 10:19:34: LP1:             Connection Timeout (To Car)
2021-04-29 10:17:31: LP1:             Connection Timeout (To Car)
2021-04-29 10:16:29: LP1:         SoC download starting
2021-04-29 09:36:43: LP1:             Connection Timeout (To Car)
2021-04-29 09:34:41: LP1:             Connection Timeout (To Car)
2021-04-29 09:33:39: LP1:         SoC download starting
2021-04-29 09:24:43: LP1:             Connection Timeout (To Car)
2021-04-29 09:22:41: LP1:             Connection Timeout (To Car)
2021-04-29 09:21:39: LP1:         SoC download starting
2021-04-29 09:14:23: LP1:             Connection Timeout (To Car)
2021-04-29 09:12:21: LP1:             Connection Timeout (To Car)
2021-04-29 09:11:18: LP1:         SoC download starting
2021-04-29 08:25:23: LP1:             Connection Timeout (To Car)
2021-04-29 08:23:21: LP1:             Connection Timeout (To Car)
2021-04-29 08:22:19: LP1:         SoC download starting
2021-04-29 08:20:21: LP1:             Receiving status failed, StatusCode: 400
2021-04-29 08:20:18: LP1:         SoC download starting
2021-04-29 08:19:53: LP1:             Connection Timeout (To Car)
2021-04-29 08:17:50: LP1:             Connection Timeout (To Car)
2021-04-29 08:16:48: LP1:         SoC download starting
2021-04-29 08:11:50: LP1:             Connection Timeout
2021-04-29 08:11:38: LP1:         SoC download starting
2021-04-29 07:30:21: LP1:         SoC received: 100% SoC
2021-04-29 07:29:01: LP1:             Connection Timeout (To Car)
2021-04-29 07:27:58: LP1:         SoC download starting
2021-04-29 05:28:15: LP1:         SoC received: 100% SoC
2021-04-29 05:27:48: LP1:         SoC download starting
2021-04-29 03:30:44: LP1:             Connection Timeout (To Car)
2021-04-29 03:28:41: LP1:             Connection Timeout (To Car)
2021-04-29 03:27:39: LP1:         SoC download starting
2021-04-29 01:30:46: LP1:             Connection Timeout (To Car)
2021-04-29 01:28:44: LP1:             Connection Timeout (To Car)
2021-04-29 01:27:29: LP1:         SoC download starting
2021-04-29 00:12:03: LP1:             Connection Timeout (To Car)
2021-04-29 00:10:01: LP1:             Connection Timeout (To Car)
2021-04-29 00:08:58: LP1:         SoC download starting
2021-04-28 22:11:55: LP1:             Connection Timeout (To Car)
2021-04-28 22:09:52: LP1:             Connection Timeout (To Car)
2021-04-28 22:08:50: LP1:         SoC download starting
2021-04-28 20:08:51: LP1:         SoC received: 100% SoC
2021-04-28 20:08:40: LP1:         SoC download starting
2021-04-28 18:10:38: LP1:         SoC received: 100% SoC
2021-04-28 18:09:31: LP1:             Connection Timeout (To Car)
2021-04-28 18:08:28: LP1:         SoC download starting
2021-04-28 16:08:30: LP1:         SoC received: 100% SoC
2021-04-28 16:08:18: LP1:         SoC download starting
2021-04-28 15:51:07: LP1:         SoC received: 100% SoC
2021-04-28 15:50:01: LP1:             Connection Timeout (To Car)
2021-04-28 15:48:58: LP1:         SoC download starting
2021-04-28 13:48:59: LP1:         SoC received: 100% SoC
2021-04-28 13:48:49: LP1:         SoC download starting
2021-04-28 13:29:16: LP1:         New Manual SoC: 100% SoC
2021-04-28 13:24:36: LP1:         New Manual SoC: 99% SoC
2021-04-28 13:20:06: LP1:         New Manual SoC: 98% SoC
2021-04-28 13:15:06: LP1:         New Manual SoC: 97% SoC
2021-04-28 13:10:26: LP1:         New Manual SoC: 96% SoC
2021-04-28 13:05:46: LP1:         New Manual SoC: 95% SoC
2021-04-28 13:01:16: LP1:         New Manual SoC: 94% SoC
2021-04-28 12:56:56: LP1:         New Manual SoC: 93% SoC
2021-04-28 12:52:26: LP1:         New Manual SoC: 92% SoC
2021-04-28 12:47:56: LP1:         New Manual SoC: 91% SoC
2021-04-28 12:43:36: LP1:         New Manual SoC: 90% SoC
2021-04-28 12:39:05: LP1:         New Manual SoC: 89% SoC
2021-04-28 12:34:46: LP1:         New Manual SoC: 88% SoC
2021-04-28 12:30:16: LP1:         New Manual SoC: 87% SoC
2021-04-28 12:24:46: LP1:         New Manual SoC: 86% SoC
2021-04-28 12:20:26: LP1:         New Manual SoC: 85% SoC
2021-04-28 12:15:56: LP1:         New Manual SoC: 84% SoC
2021-04-28 12:11:36: LP1:         New Manual SoC: 83% SoC
2021-04-28 11:48:47: LP1:         SoC received: 82% SoC
2021-04-28 11:48:38: LP1:         SoC download starting
Mal von unten nach oben gelesen: Auto wurde um 11:48 Uhr angesteckt, da wird direkt der SoC abgefragt. Laden startet kurz danach, Manual SoC-Berechnung funktioniert gut. Genau zwei Stunden später, um 13:48, nächste Abfrage, wieder erfolgreich, 100% SoC. Soweit alles gut.

Weitere zwei Stunden später, 15:48 Uhr, nächster Abruf (obwohl nicht mehr geladen wurde, das wäre ein cooles Feature, wenn nicht mehr abgefragt wird, wenn das Auto weiter angesteckt ist und nicht geladen wird). Da gibt es einen Timeout, 3 Minuten später wird erneut versucht und das ist dann um 15:51 erfolgreich, auch ok, es soll ja immer zwei Versuche geben. Aber warum wird dann um 16:08 Uhr erneut abgefragt? Ähnliches zwischen 0:08 Uhr und 1:28 Uhr, auch hier wird der 120-Minuten-Abstand nicht eingehalten. Zwischen 7:30 und 8:11 Uhr nochmal.

Um 9:20 Uhr wurde der Wagen dann kurz abgesteckt (da habe ich gemerkt, dass die 12V-Batterie leer war) und dann wieder angesteckt. In den Folgestunden sind natürlich alle Abfragen gescheitert wegen der leeren 12V-Batterie, aber man kann am Log gut erkennen, dass da häufiger als alle 120 Minuten abgefragt wird.

Fazit: Es sieht so aus, als ob die Regel, dass bei Scheitern der Abfrage kurz danach ein zweiter Versuch gestartet, aber ansonsten der Abfragerhythmus beibehalten wird, nicht ganz richtig funktioniert.
Flocki
Beiträge: 109
Registriert: Fr Aug 28, 2020 12:43 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von Flocki »

Der Abruf wird gestartet, wenn:
- Der Abruf per Dashboard manuell gestartet wird
- Das eingestellte Intervall um ist
- Das Auto angesteckt wird
- Die openWB die Ladung freigibt

Insofern sind die "zusätzlichen" Abrufe wahrscheinlich auf Ladestarts (z.B. nach einer Unterbrechung beim PV-Laden oder dem Start einer Nachtladung) zurückzuführen.
Zuletzt geändert von Flocki am Do Apr 29, 2021 2:36 pm, insgesamt 1-mal geändert.
gorthon
Beiträge: 139
Registriert: So Okt 04, 2020 4:33 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von gorthon »

Interessant. Nachtladen ist nicht konfiguriert und der SoC war ja schon bei 100%, ein Laden wurde also nicht mehr gestartet, insofern erklärt sich das nicht ganz. Bei höherem Loglevel kann man auch den Grund sehen, der den Abruf getriggert hat, oder? Dann müsste ich also mal den Debuglevel erhöhen und hoffen, dass in der Zeit dann so etwas auftritt.
Flocki
Beiträge: 109
Registriert: Fr Aug 28, 2020 12:43 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von Flocki »

Bei 100% lädt zwar das Auto nicht mehr, aber die WB sagt dem Auto ja trotzdem "du könntest jetzt laden wenn du wolltest" und das gilt als Ladestart.

In der aktuellen Version ist auch auf höheren Debug-Stufen nicht direkt ersichtlich, was der Trigger war, Wenn aber bei "Next Update:" eine negative Zeit steht, dann war es nicht der Timer, sondern ein anderer Trigger.

In der nächsten Version des Moduls wird das dann auch in Klartext angezeigt.
gorthon
Beiträge: 139
Registriert: So Okt 04, 2020 4:33 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von gorthon »

Flocki hat geschrieben: Do Apr 29, 2021 12:48 pm Bei 100% lädt zwar das Auto nicht mehr, aber die WB sagt dem Auto ja trotzdem "du könntest jetzt laden wenn du wolltest" und das gilt als Ladestart.
Hm, d.h. wenn das Auto voll ist und den Rest des Tages der sich Wolken und Sonne abwechseln, finden dauernd Ladestarts statt und der SoC wird abgefragt. Das ist ja eigentlich nicht so sinnvoll. Lässt sich die SoC-Abfrage bei Ladestart nicht verhindern? Wozu soll sie überhaupt gut sein, denn im Gegensatz zur Abfrage bei Anstecken sollte sich der SoC ja nicht verändert haben, nur weil jetzt das Laden gestartet wird (von minimaler Selbstentladung mal abgesehen).
Flocki
Beiträge: 109
Registriert: Fr Aug 28, 2020 12:43 pm

Re: Hyundai Bluelink wieder kein SoC???

Beitrag von Flocki »

Von der Logik gebe ich dir voll recht. leider ist, so wie die Module heute in die Open-WB-Landschaft eingebaut die entsprechende Implementierung nicht trivial, da die nötigen Informationen in den Modulen per se mal nicht vorliegen, sondern das einige Krücken erfordert, sofern es überhaupt möglich ist.

Ich setze viel Hoffnung auf Version 2.0 von der open WB, wo das ganze Thema anscheinend gut aufgeräumt und viel strukturierter als heute angegangen wird.
Antworten