openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Fragen zur Nutzung, Features, usw..
solargy
Beiträge: 13
Registriert: Di Dez 15, 2020 8:30 am

openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von solargy »

Hallo Liebe Community,

Ich habe mir ein RPI3 B+ erworben und wollte damit ein bischen spielen bis eine richtige openWB Wallbox bei mir in der Garaje landet. Ich habe eine PV Anlage mit Kostal Plenticore 10 und KSEM, beide sind im Netzwerk verbunden.

Auf dem RPI3 habe ich ein Raspberry Pi OS Lite geflascht und die allgemeine Einstellungen vorgenommen.
Dann habe ich auf dem RPI3 die openWB installiert wie hier beschrieben.https://openwb.de/main/wp-content/uploa ... nWB_v2.pdf
Alles hat super gut geklappt und auch die Kostal System mit openWB erfolgreich verbunden.
Ich wollte dann auf dem RPI3 auch ioBroker ausprobieren um die openWB weiter in der Haussteuerung zu integrieren.
Nach der Installation scheint der ioBroker nicht aufrufbar in seiner Weboberflaeche zu sein.

Code: Alles auswählen

==========================================================================
 ioBroker was installed successfully
Open http://192.168.178.41 192.168.193.5:8081 in a browser and start configuring!
Komisch ist das hier zwei IP Adressen angezeigt werden sind. Weder die erste

Code: Alles auswählen

http://192.168.178.41:8081
noch die letze

Code: Alles auswählen

http://192.168.193.5:8081
koennen in Browser aufgerufen werden.
RPI 3 und der Rechner befinden sich in dem gleichem Netwerk. Der RPI 3 ist abrufbar und man kann alles einstellen.
Der ioBroker scheint also auf dem RPI3 zu laufen:

Code: Alles auswählen

 PID   USER     PR   NI   VIRT    RES    SHR S  %CPU  %MEM   TIME+  COMMAND                                               
 1465 xrdp      20   0   35192  24116   8164 S  31.4   2.5   0:22.05 xrdp                                                    
 1496 pi        20   0  269940  61208  36360 S   7.9   6.5   0:11.64 Xorg                                                    
25494 pi        20   0   86060  28092  21832 S   4.0   3.0   0:18.02 lxterminal                                              
 2525 iobroker  20   0  138228  51476  27940 S   2.0   5.4   0:21.43 node                                                    
  444 mosquit+  20   0   11304   6688   5200 S   1.3   0.7   0:14.49 mosquitto                                               
 2851 iobroker  20   0  133276  47236  27772 S   1.3   5.0   0:20.69 node                                                    
 3531 iobroker  20   0  135228  48584  27868 S   1.3   5.1   0:20.83 node                                                    
16732 pi        20   0   10760   2916   2500 R   1.0   0.3   0:07.72 top                                                     
24441 pi        20   0   21984  13600   7392 S   0.7   1.4   0:10.02 python3                                                 
    9 root      20   0       0      0      0 S   0.3   0.0   0:01.05 ksoftirqd/0                                             
  505 root      20   0  202196  37520  25064 S   0.3   4.0   0:12.38 Xorg                                                    
  872 lightdm   20   0  119704  42624  19600 S   0.3   4.5   0:10.26 pi-greeter                                              
 1776 pi        20   0   63224  15400  12492 S   0.3   1.6   0:00.81 openbox                                                 
 1782 pi        20   0  436024  32628  26084 S   0.3   3.4   0:03.94 lxpanel                                                 
 2462 iobroker  20   0  133516  44768  28076 S   0.3   4.7   0:04.43 node                                                    
    1 root      20   0   34812   8344   6488 S   0.0   0.9   0:07.18 systemd
Beim "ip a" in RPI3 Terminal ergibt sich komischerweise zwei Geraete in meinem Netz IP Adresse zu vergeben.

Code: Alles auswählen

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:xx.xx.xx.xx brd ff:ff:xx:xx:xx:xx
    inet [b]192.168.178.41/24[/b] brd 192.168.178.255 scope global dynamic noprefixroute eth0
       valid_lft 835833sec preferred_lft 727833sec
    inet [b]192.168.193.5/24[/b] brd 192.168.193.255 scope global eth0:0
       valid_lft forever preferred_lft forever
    inet6 2003:d4:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 7197sec preferred_lft 1797sec
    inet6 fe80::15a8:xxxx:xxxx:xxxx/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether b8:27:xx:xx:xx:xx brd ff:ff:xx:xx:xx:xx
Ich wusste leider nicht woher diese zweite IP Adresse kommt:192.168.193.5/24
Die openWB funktionierte aber weiter sehr gut.

Ich habe dann den RPI3 komplett neue mit Raspberry PI OS geflascht und die Installation anderesrum durchgefuehrt.
Also erstmal ioBroker und dann openWB.
Wenn nur der ioBroker installiert ist, da scheint alles einwandfrei zu funktionieren.
Beim "ip a" ergibt sich nur eine 192.168.178.41 IP Adresse.
Ich habe dann die openWB wie hier beschrieben, installiert: https://openwb.de/main/wp-content/uploa ... nWB_v2.pdf (Ab dem Punkt In der Schell folgendes eingeben)
Wenn die Installation fertig ist dann faengt die Hoelle an. Weder der ioBroker ist in der WebOberflaeche erreichbar noch die openWB.

Beim "ip a" scheint die Installation der openWB Netzwerk Aenderungen vorzunehmen/vorgenommen zu haben. Da erscheint nach der openWB Installation, wieder diese zweite problematische IP Adresse (192.168.193.5/24), wie hier oben gezeigt wurde.

Code: Alles auswählen

    inet 192.168.178.41/24 brd 192.168.178.255 scope global dynamic noprefixroute eth0
    valid_lft 833560sec preferred_lft 725560sec
    inet 192.168.193.5/24 brd 192.168.193.255 scope global eth0:0
Hat jemanden Ahnung was ist passiert geworden? Warum fummelt die openWB tief im Netzwerksetup herum?

Vielen Dank!
openWB
Site Admin
Beiträge: 6811
Registriert: So Okt 07, 2018 1:50 pm

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von openWB »

Warum fummelt die openWB tief im Netzwerksetup herum?
So tief ist das auch nicht.
openWB nutzt immer ein eigenes Subnetz um mit den "eigenen" Komponenten zu kommunizieren ohne das ein Setup erforderlich ist (EVU Kit und co..)
Supportanfragen bitte NICHT per PN stellen.
Hardwareprobleme bitte über die Funktion Debug Daten senden mitteilen oder per Mail an support@openwb.de
solargy
Beiträge: 13
Registriert: Di Dez 15, 2020 8:30 am

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von solargy »

openWBSupport hat geschrieben: Mi Dez 23, 2020 6:05 am
Warum fummelt die openWB tief im Netzwerksetup herum?
So tief ist das auch nicht.
openWB nutzt immer ein eigenes Subnetz um mit den "eigenen" Komponenten zu kommunizieren ohne das ein Setup erforderlich ist (EVU Kit und co..)
Ahaa, wusste ich gar nicht dass openWB das macht, ich dachte immer da sind irgendwelche Buggy Geraete bei mir im Haus.
Wie kann man es vermeiden dass diese neue interne openWB IP Adresse den ioBroker beeintraechtigt?

Vielen Dank.
openWB
Site Admin
Beiträge: 6811
Registriert: So Okt 07, 2018 1:50 pm

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von openWB »

Sollte sie garnicht.
Ansonsten kann man für den ioBroker sicher auch die listen address mit angeben in der config.
Supportanfragen bitte NICHT per PN stellen.
Hardwareprobleme bitte über die Funktion Debug Daten senden mitteilen oder per Mail an support@openwb.de
solargy
Beiträge: 13
Registriert: Di Dez 15, 2020 8:30 am

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von solargy »

openWBSupport hat geschrieben: Mi Dez 23, 2020 9:54 am Sollte sie garnicht.
Ansonsten kann man für den ioBroker sicher auch die listen address mit angeben in der config.
Ich frage mich warum wenn man den ioBroker installiert nimmt er auch die Adresse von openWB.

Code: Alles auswählen

 ioBroker was installed successfully
Open http://192.168.178.41 192.168.193.5:8081 in a browser and start configuring!
und wenn da keine openWB gibts dann startet ioBroker normal und zieht auch die richtige Adresse.

Code: Alles auswählen

 ioBroker was installed successfully
Open http://192.168.178.41:8081 in a browser and start configuring!
Ansonsten kann man für den ioBroker sicher auch die listen address mit angeben in der config.
Wie funktioniert das genau? Ich kenne mich damit wenig aus. Wo soll ich die richtige IP Adresse die ioBroker zieht eingeben?

Vielen vielen Dank!
ftd
Beiträge: 64
Registriert: Mo Feb 10, 2020 11:30 am

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von ftd »

Wie funktioniert das genau? Ich kenne mich damit wenig aus. Wo soll ich die richtige IP Adresse die ioBroker zieht eingeben?
Im Admin-Adapter auf alle IPs hören lassen?!

AdminAdapter.jpg
AdminAdapter.jpg (3.91 KiB) 2576 mal betrachtet
solargy
Beiträge: 13
Registriert: Di Dez 15, 2020 8:30 am

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von solargy »

ftd hat geschrieben: Mi Dez 23, 2020 4:30 pm
Wie funktioniert das genau? Ich kenne mich damit wenig aus. Wo soll ich die richtige IP Adresse die ioBroker zieht eingeben?
Im Admin-Adapter auf alle IPs hören lassen?!


AdminAdapter.jpg
Das Problem ist dass nach der Installation der openWB, kann ich nicht mehr auf der Weboberflaeche des ioBroker kommen und die openWB scheint auch beeintraechtigt zu sein (zeigt immer die Seite: openWB bereitet sich vor oder aehnliches). Die Installation der openWB erzeugt diese neue IP Adresse 192.168.193.5/24 die aendert auch was der ioBroker selbst als IP Adresse fuer seine Verbindung braucht.
Es scheint also dass ioBroker will auch mit der neuen erzeugten IP Adresse sich zu verbinden, d.h.

Code: Alles auswählen

==========================================================================
 ioBroker was installed successfully
Open http://192.168.178.41 192.168.193.5:8081 in a browser and start configuring!
Das bedeutet das ioBroker weiss jetzt nich mehr welche IP Adresse er verwenden soll, da die zwei Adressen sich irgendwie kombiniert haben. Also, weiss ich nicht welche IP Adresse soll man nehmen um sich bei der ioBroker WebO anzumelden?

Danke fuer die Antworten!
ftd
Beiträge: 64
Registriert: Mo Feb 10, 2020 11:30 am

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von ftd »

solargy hat geschrieben: Mi Dez 23, 2020 7:04 pm Das bedeutet das ioBroker weiss jetzt nich mehr welche IP Adresse er verwenden soll, da die zwei Adressen sich irgendwie kombiniert haben. Also, weiss ich nicht welche IP Adresse soll man nehmen um sich bei der ioBroker WebO anzumelden?
Ich wüsste nicht, warum ich beide Systeme zusammen installieren sollte. Ich meine, die openWB kommt fix und fertig mit Hard- und Software geliefert. Mein ioBroker läuft auf einem seperatem System, in dem ich die openWB einbinden kann.

Für Testzwecke hab ich in einem LXC-Container lediglich die openWB Software installiert. Hier kann ich jederzeit schauen, wie und wann sich z.B. ein MQTT-Topic ändert, mein eigenes Layout testen etc. .... um in der ioBroker-Welt zu funktionieren.

Für dich so ein Szenario nachgestellt:

1) ioBroker installiert
2) openWB installiert
3) läuft via 192.168.1.71 hier im Test

Was passiert, wenn du direkt die Einstellungen aufrufst?

http://192.168.1.71/openWB/web/settings/settings.php

ioBrokerundopenWB.jpg
solargy
Beiträge: 13
Registriert: Di Dez 15, 2020 8:30 am

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von solargy »

ftd hat geschrieben: Mi Dez 23, 2020 10:38 pm
solargy hat geschrieben: Mi Dez 23, 2020 7:04 pm Das bedeutet das ioBroker weiss jetzt nich mehr welche IP Adresse er verwenden soll, da die zwei Adressen sich irgendwie kombiniert haben. Also, weiss ich nicht welche IP Adresse soll man nehmen um sich bei der ioBroker WebO anzumelden?
Ich wüsste nicht, warum ich beide Systeme zusammen installieren sollte. Ich meine, die openWB kommt fix und fertig mit Hard- und Software geliefert. Mein ioBroker läuft auf einem seperatem System, in dem ich die openWB einbinden kann.

Für Testzwecke hab ich in einem LXC-Container lediglich die openWB Software installiert. Hier kann ich jederzeit schauen, wie und wann sich z.B. ein MQTT-Topic ändert, mein eigenes Layout testen etc. .... um in der ioBroker-Welt zu funktionieren.

Für dich so ein Szenario nachgestellt:

1) ioBroker installiert
2) openWB installiert
3) läuft via 192.168.1.71 hier im Test

Was passiert, wenn du direkt die Einstellungen aufrufst?

http://192.168.1.71/openWB/web/settings/settings.php


ioBrokerundopenWB.jpg
Vielen Dank fuer deine Antwort!
Wie schon oben beschrieben, ich will erstmal die openWB Software auf einem RPI3 installieren und schauen ob alles laueft und auch eventuell spaeter die openWB Wallbox mir zu erwerben.
Um Resourcen zu sparen wollte ich mir NICHT zwei RPI kaufen, aber die openWB und ioBroker auf einem System laufen zu lassen.
Bei der Instalation wie schon oben beschrieben scheint es die openWB eine zweite IP Adresse (192.168.193.5) fuer ihre eigene Vernetzung der Komponenten zu erstellen und diese openWB eigene Adresse macht sehr grosse Problemen fuer den ioBroker. Nach erfolgreiche Installation des ioBrokers(openWB Software schon frueher erfolgreich auf dem RPI installiert) sagt er:

Code: Alles auswählen

 ioBroker was installed successfully
Open http://192.168.178.41 192.168.193.5:8081 in a browser and start configuring!
Daher keine von den 2 Adressen, weder http://192.168.178.41:8081 noch http://192.168.193.5:8081, ein Lebenszeichen zeigen. Noch komischer ist das Fakt, dass der ioBroker zeigt nach seiner Installation 2 IP Adressen (http://192.168.178.41 192.168.193.5:8081).

Auch das openWB Link funktioniert nicht mehr und beim Laden zeigt: openWB bereitet sich vor(genauen Text habe ich nicht vor mir)... und weiter geht es nicht. Ich habe die beiden Systemen auch umgekehrt installiert, den ioBroker zuerst und dann openWB Software und die Ergebnisse sind gleich schlecht.
Es scheint dass beide Systeme sind miteinander nicht kompatibel und koennen leider auf einem gleichen RPI3 gleichzeitig nicht laufen.

Mit LXC Containers habe ich nie gearbeitet, weiss was die machen aber selbst habe ich mit denen nicht gearbeitet und wie genau man sie installiert auch nicht. Wie hast Du deine LXC Containers installiert und auf welchem System?

Die einzige Loesungen, wie ich es sehe sind:
1. openWB Software auf einem RPI installieren und ioBroker auf einem zweiten.
2. ein anderes System als RPI zu nehmen wo man die LXC Containers installieren kann, jeweils ein LXC Container fuer ioBroker und openWB.
Das ganze macht dann wenig Sinn, vielleicht fuer die Leute die sich in dem Bereich sehr gut auskennen, aber bestimmt nicht fuer Einsteiger/Laien, wie ich.

Vielen Dank!
LutzB
Beiträge: 1943
Registriert: Di Feb 25, 2020 9:23 am

Re: openWB und ioBroker auf RPI 3 installiert, WebOberflaeche antwortet nicht

Beitrag von LutzB »

Auf welcher IP und welchem Port läuft denn welches Programm? Ich kann mir nicht vorstellen, dass ioBroker durch eine zusätzliche IP aus dem Tritt kommt.

Was kommt bei

Code: Alles auswählen

sudo netstat -ltpn
Antworten