Rückmeldungen Stable 1.9.265

Fragen zur Nutzung, Features, usw..
vuffiraa
Beiträge: 143
Registriert: Mo Apr 19, 2021 11:26 am

Re: Rückmeldungen Stable 1.9.265

Beitrag von vuffiraa »

chri1985 hat geschrieben: Do Mai 12, 2022 8:43 am Hallo zusammen,

bei mir ist seit dem Update der Input zu PV und Hausverbrauch weg.
Das Monitoring im Fronius Solar.web funktioniert.
openwb.pngopenwb.png
Hallo,

schreib mal etwas zu deiner Installation und der Konfiguration der einzelnen Komponenten in der openWB.
Was zeigen Status und Debug-Log?
Um das hier bei den Rückmeldungen übersichtlich zu halten, kannst du gerne ein neues Thema mit den Informationen beginnen.

VG
openWB serie 2 custom 11kW
Skoda Enyaq iV80 (bestellt 05/2021)
PV 9,4kWp SSW, Fronius Symo 8.2-3-M, Fronius Smart Meter 63A
JB_Sullivan
Beiträge: 192
Registriert: Mi Okt 07, 2020 6:34 pm

Re: Rückmeldungen Stable 1.9.265

Beitrag von JB_Sullivan »

Ich glaube ich habe gerade einen Bug in Smarthome2.0 entdeckt.

Wenn man in Smarthome2.0, verschiedene Aktoren bereits eingerichtet hat, etwas an den Einstellungen ändert (nicht an allen, sondern nur an einem), dann aber diese Änderung doch nicht speichert, sondern einfach den Browser Tab mit den Einstellungen schließt, werden die Felder ALLER Aktoren, welchen einen Namen oder ein Passwort benötigen durch "NaN" ersetzt.

Das führt dazu das die Aktoren nicht mehr wie zuvor funktionieren, da Login Name, Passwörter und Aktor Name für openWB nun nur noch "NaN" heißen. Kann das ggf. jemand bestätigen?
chri1985
Beiträge: 18
Registriert: Do Jan 21, 2021 2:14 pm

Re: Rückmeldungen Stable 1.9.265

Beitrag von chri1985 »

vuffiraa hat geschrieben: Fr Mai 13, 2022 6:46 am
Hallo,

schreib mal etwas zu deiner Installation und der Konfiguration der einzelnen Komponenten in der openWB.
Was zeigen Status und Debug-Log?
Um das hier bei den Rückmeldungen übersichtlich zu halten, kannst du gerne ein neues Thema mit den Informationen beginnen.

VG
Erledigt, danke!
Benutzeravatar
mrinas
Beiträge: 893
Registriert: Mi Jan 29, 2020 10:12 pm

Re: Rückmeldungen Stable 1.9.265

Beitrag von mrinas »

Ich hab' mit der .265 stable ein Problem mit den Einstellungen der PV-Ladung. Ich hab' gestern sowohl die Stromstärke für die Phasenumschaltung angepasst als auch das Ladelimit von 85 auf 100% angehoben. Beides hatte keinen Effekt. Ich konnte in loadvars entdecken dass die Konfiguration nun aus dem Broker gelesen wird, hier war in der Tat noch das alte Limit (85%) enthalten, obwohl die Einstellungen in der UI auf 100% standen. Hatte vorher schon den Wert verändert, gespeichert, wieder auf 100% gesetzt - leider ohne Erfolg.

Hab' mit MQTTExplorere den Wert 'config/set/pv/lp/1/socLimitation' auf 100 gesetzt und wurde der LP entsperrt und die Ladung hat begonnen. Werden die Änderungen aus der UI ggf. nicht dorthin geschrieben?

[Update]
Hab' jetzt mal ein wenig gesucht und bin zu folgendem Schluss gekommen:
Auto ist inzwischen auf 100% aufgeladen, in dein Einstellungen das SoC Limit für PV Laden wieder auf 85 konfiguriert und gespeichert. Ladepunkt bleibt aktiv.
Wenn ich das richtig beobachtet habe setzt der Regler in den Einstellungen das Topic 'maxSocToChargeTo' wohingegen die Regelung auf 'maxSoc' über die Variable stopchargepvpercentagelp1 zurückgreift.
Das topic maxSocToChargeTo wird in loadvars zwar einer Variable zugewiesen, VSCode hat aber keine Treffer in den Regelscripten angezeigt. Kann das so sein oder habe ich schlicht etwas übersehen?
Screenshot 2022-05-15 223301.png
Screenshot 2022-05-15 223041.png
4kWp + 3,6kWp SMA PV + EnergyMeter, openWB Standard+, openWB custom als zweiter externer Ladepunkt, Peugeot e2008, Tesla Model Y LR, openWB custom inzwischen über openWB 2.0 gesteuert.
Gr33n93
Beiträge: 23
Registriert: Sa Feb 06, 2021 7:17 am

Re: Rückmeldungen Stable 1.9.265

Beitrag von Gr33n93 »

Mir ist aufgefallen das wenn ich von der Einstellung PV Laden mit Vorrang EV Einstelle das Auto wunderbar anfängt zu Laden. Wenn ich dann aber auf Vorrang Hausspeicher umstelle hört das Auto nicht auf zu laden obwohl die Leistung der Pv nicht reicht um den bei Smart Home 2.0 eingestellt min Speicher Ladewert zu erreichen. Mache ich hier etwas Falsch oder ist das tatsächlich Merkwürdig?

Speicher ist ein BYD HVS mit Kostal System
Amok83
Beiträge: 505
Registriert: Mi Dez 02, 2020 10:17 am

Re: Rückmeldungen Stable 1.9.265

Beitrag von Amok83 »

Wenn du mitten im Ladevorgang die Einstellungen änderst, dann läuft erst die Entprellzeit ab.
Du kannst manuell stoppen und wieder in den Lademodus wechseln oder du wartest einfach die eingestellte Zeit ab.
Kostal Piko 17
Kostal Plenticore Plus 10
Kostal Smart Energy Meter
ioBroker
openWB series2 Duo
Cupra Leon ST eHybrid
Bucky2k
Beiträge: 338
Registriert: Sa Nov 09, 2019 1:17 pm

Re: Rückmeldungen Stable 1.9.265

Beitrag von Bucky2k »

Also mein Debug Log ist weiter komplett voll mit "Warning" und "Fatal" bzgl. Regulation Loop. Wie bekomme ich dass denn nun behoben? Beide Ladepunkte arbeiten grundsätzlich wie sie sollen.

Code: Alles auswählen

2022-05-25 11:26:28: PID: 12157: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:26:18: PID: 10819: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:26:00: PID: 8086: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:25:04: PID: 1099: ##### cron5min.sh finished ##### (LV0)
2022-05-25 11:25:03:  Load: 1.33 1.13 1.19
2022-05-25 11:25:02: PID: 1099: ##### cron5min.sh started ##### (LV0)
2022-05-25 11:24:29: PID: 28119: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:24:09: PID: 25436: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:49: PID: 22683: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:39: PID: 21305: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:19: PID: 18588: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:09: PID: 17228: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:59: PID: 15802: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:49: PID: 14444: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:39: PID: 13077: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:29: PID: 11713: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:19: PID: 10126: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:16: PID: 7574: **** FATAL ********************************* (LV0)
2022-05-25 11:22:16: PID: 7574: **** FATAL Regulation loop needs 25 seconds (LV0)
2022-05-25 11:22:16: PID: 7574: **** FATAL ********************************* (LV0)
2022-05-25 11:22:04: PID: 9102: Pause nach Umschaltung: 2s (LV0)
2022-05-25 11:21:50: PID: 6180: **** FATAL ********************************* (LV0)
2022-05-25 11:21:50: PID: 6180: **** FATAL Regulation loop needs 9 seconds (LV0)
2022-05-25 11:21:50: PID: 6180: **** FATAL ********************************* (LV0)
2022-05-25 11:21:40: PID: 4799: **** FATAL ********************************* (LV0)
2022-05-25 11:21:40: PID: 4799: **** FATAL Regulation loop needs 9 seconds (LV0)
2022-05-25 11:21:40: PID: 4799: **** FATAL ********************************* (LV0)
2022-05-25 11:21:30: PID: 3420: **** FATAL ********************************* (LV0)
2022-05-25 11:21:30: PID: 3420: **** FATAL Regulation loop needs 9 seconds (LV0)
2022-05-25 11:21:30: PID: 3420: **** FATAL ********************************* (LV0)
2022-05-25 11:21:19: PID: 2044: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:21:09: PID: 662: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:58: PID: 31685: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:48: PID: 30306: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:40: PID: 28914: **** FATAL ********************************* (LV0)
2022-05-25 11:20:40: PID: 28914: **** FATAL Regulation loop needs 10 seconds (LV0)
2022-05-25 11:20:40: PID: 28914: **** FATAL ********************************* (LV0)
2022-05-25 11:20:28: PID: 27536: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:18: PID: 26157: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:08: PID: 24331: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:03: PID: 24333: ##### cron5min.sh finished ##### (LV0)
2022-05-25 11:20:02:  Load: 1.00 0.98 1.18
LutzB
Beiträge: 1949
Registriert: Di Feb 25, 2020 9:23 am

Re: Rückmeldungen Stable 1.9.265

Beitrag von LutzB »

mrinas hat geschrieben: So Mai 15, 2022 7:40 am Ich hab' mit der .265 stable ein Problem mit den Einstellungen der PV-Ladung. Ich hab' gestern sowohl die Stromstärke für die Phasenumschaltung angepasst als auch das Ladelimit von 85 auf 100% angehoben. Beides hatte keinen Effekt. Ich konnte in loadvars entdecken dass die Konfiguration nun aus dem Broker gelesen wird, hier war in der Tat noch das alte Limit (85%) enthalten, obwohl die Einstellungen in der UI auf 100% standen. Hatte vorher schon den Wert verändert, gespeichert, wieder auf 100% gesetzt - leider ohne Erfolg.

Hab' mit MQTTExplorere den Wert 'config/set/pv/lp/1/socLimitation' auf 100 gesetzt und wurde der LP entsperrt und die Ladung hat begonnen. Werden die Änderungen aus der UI ggf. nicht dorthin geschrieben?

[Update]
Hab' jetzt mal ein wenig gesucht und bin zu folgendem Schluss gekommen:
Auto ist inzwischen auf 100% aufgeladen, in dein Einstellungen das SoC Limit für PV Laden wieder auf 85 konfiguriert und gespeichert. Ladepunkt bleibt aktiv.
Wenn ich das richtig beobachtet habe setzt der Regler in den Einstellungen das Topic 'maxSocToChargeTo' wohingegen die Regelung auf 'maxSoc' über die Variable stopchargepvpercentagelp1 zurückgreift.
Das topic maxSocToChargeTo wird in loadvars zwar einer Variable zugewiesen, VSCode hat aber keine Treffer in den Regelscripten angezeigt. Kann das so sein oder habe ich schlicht etwas übersehen?

Screenshot 2022-05-15 223301.png
Screenshot 2022-05-15 223041.png
Die Konfiguration wird nach wie vor aus der openwb.conf gelesen. Im Broker wird lediglich der Wert nochmal für das UI hinterlegt. Die Einstellungen zu den Lademodi nutzen ausschließlich den Broker und nicht mehr den Weg über PHP und openwb.conf.

Die Einstellung "maxnurpvsoclp1" wird in der "nurpv.sh" Zeile 89 verwendet.
"stopchargepvpercentagelp1" (oder "...lp2") taucht hingegen in "nurpv.sh" sowie "minundpv.sh" auf.

Beide Einstellungen sind auch in der Einstellungsseite vorhanden, schließen sich aber gegenseitig aus. Wenn nur ein Ladepunkt vorhanden ist, wird "maxSocToChargeToLp1" (-> "maxnurpvsoclp1" in der openwb.conf) sichtbar. Wenn mehrere Ladepunkte eingerichtet sind, werden die Topics "maxSoc" der Ladepunkte (-> "stopchargepvpercentagelp1" in der openwb.conf) angezeigt. In den Bereichen wurde schon eine gefühlte Ewigkeit keine Anpassung vorgenommen.

Dementsprechend sieht auch die Behandlung in der "nurpv.sh" aus:

Code: Alles auswählen

	if [[ $lastmanagement == "0" ]]; then
		if [[ $socmodul != "none" ]]; then
			if (( soc < minnurpvsoclp1 )); then
				if grep -q 0 "/var/www/html/openWB/ramdisk/ladestatus"; then
					runs/set-current.sh "$minnurpvsocll" all
					openwbDebugLog "CHARGESTAT" 0 "LP1, Lademodus NurPV. Ladung mit ${minnurpvsocll}A, $soc % SoC noch nicht erreicht"

					openwbDebugLog "MAIN" 1 "Starte PV Laden da $sofortsoclp1 % zu gering"
				else
					if (( llalt != minnurpvsocll )); then
						runs/set-current.sh "$minnurpvsocll" all
						openwbDebugLog "CHARGESTAT" 0 "LP1, Lademodus NurPV. Ladung geändert auf ${minnurpvsocll}A, $soc % SoC noch nicht erreicht"
					fi
				fi
				echo "Ladung mit ${minnurpvsocll}A, da $minnurpvsoclp1 % SoC noch nicht erreicht" > ramdisk/lastregelungaktiv
			exit 0
			fi
			if (( soc > maxnurpvsoclp1 )); then
				if grep -q 1 "/var/www/html/openWB/ramdisk/ladestatus"; then
					runs/set-current.sh 0 all
					openwbDebugLog "CHARGESTAT" 0 "LP1, Lademodus NurPV. Ladung gestoppt, $soc % SoC erreicht"
					openwbDebugLog "MAIN" 1 "Beende PV Laden da $sofortsoclp1 % erreicht"
				fi
			exit 0
			fi
		fi
	fi
"maxnurpvsoclp1" wir in einem Block verwendet, der nur bei einem Ladepunkt ausgeführt wird ($lastmanagement == "0").
"stopchargepvpercentagelp1" (oder "...lp2") wird genutzt, wenn "Sperren nach Abstecken" der Ladepunkte deaktiviert ist.

Das ist definitiv nicht alles sauber gelöst und die ganzen Abhängigkeiten lassen einem graue Haare wachsen. Das wird aber definitiv in 1.9 nicht mehr angepasst. Genau für sowa ist ja die 2.0 mit einer strukturierten Codebasis da.
LutzB
Beiträge: 1949
Registriert: Di Feb 25, 2020 9:23 am

Re: Rückmeldungen Stable 1.9.265

Beitrag von LutzB »

Bucky2k hat geschrieben: Mi Mai 25, 2022 9:28 am Also mein Debug Log ist weiter komplett voll mit "Warning" und "Fatal" bzgl. Regulation Loop. Wie bekomme ich dass denn nun behoben? Beide Ladepunkte arbeiten grundsätzlich wie sie sollen.

Code: Alles auswählen

2022-05-25 11:26:28: PID: 12157: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:26:18: PID: 10819: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:26:00: PID: 8086: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:25:04: PID: 1099: ##### cron5min.sh finished ##### (LV0)
2022-05-25 11:25:03:  Load: 1.33 1.13 1.19
2022-05-25 11:25:02: PID: 1099: ##### cron5min.sh started ##### (LV0)
2022-05-25 11:24:29: PID: 28119: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:24:09: PID: 25436: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:49: PID: 22683: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:39: PID: 21305: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:19: PID: 18588: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:23:09: PID: 17228: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:59: PID: 15802: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:49: PID: 14444: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:39: PID: 13077: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:29: PID: 11713: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:19: PID: 10126: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:22:16: PID: 7574: **** FATAL ********************************* (LV0)
2022-05-25 11:22:16: PID: 7574: **** FATAL Regulation loop needs 25 seconds (LV0)
2022-05-25 11:22:16: PID: 7574: **** FATAL ********************************* (LV0)
2022-05-25 11:22:04: PID: 9102: Pause nach Umschaltung: 2s (LV0)
2022-05-25 11:21:50: PID: 6180: **** FATAL ********************************* (LV0)
2022-05-25 11:21:50: PID: 6180: **** FATAL Regulation loop needs 9 seconds (LV0)
2022-05-25 11:21:50: PID: 6180: **** FATAL ********************************* (LV0)
2022-05-25 11:21:40: PID: 4799: **** FATAL ********************************* (LV0)
2022-05-25 11:21:40: PID: 4799: **** FATAL Regulation loop needs 9 seconds (LV0)
2022-05-25 11:21:40: PID: 4799: **** FATAL ********************************* (LV0)
2022-05-25 11:21:30: PID: 3420: **** FATAL ********************************* (LV0)
2022-05-25 11:21:30: PID: 3420: **** FATAL Regulation loop needs 9 seconds (LV0)
2022-05-25 11:21:30: PID: 3420: **** FATAL ********************************* (LV0)
2022-05-25 11:21:19: PID: 2044: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:21:09: PID: 662: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:58: PID: 31685: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:48: PID: 30306: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:40: PID: 28914: **** FATAL ********************************* (LV0)
2022-05-25 11:20:40: PID: 28914: **** FATAL Regulation loop needs 10 seconds (LV0)
2022-05-25 11:20:40: PID: 28914: **** FATAL ********************************* (LV0)
2022-05-25 11:20:28: PID: 27536: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:18: PID: 26157: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:08: PID: 24331: **** WARNING **** Regulation loop needs 8 seconds (LV0)
2022-05-25 11:20:03: PID: 24333: ##### cron5min.sh finished ##### (LV0)
2022-05-25 11:20:02:  Load: 1.00 0.98 1.18
Wenn Nix schlimmes passiert: ignorieren. Ansonsten müsstest Du schon sagen, welche Module (inklusive Ladepunkte) genutzt werden.
Benutzeravatar
mrinas
Beiträge: 893
Registriert: Mi Jan 29, 2020 10:12 pm

Re: Rückmeldungen Stable 1.9.265

Beitrag von mrinas »

LutzB hat geschrieben: Mi Mai 25, 2022 10:40 am
mrinas hat geschrieben: So Mai 15, 2022 7:40 am Ich hab' mit der .265 stable ein Problem mit den Einstellungen der PV-Ladung. Ich hab' gestern sowohl die Stromstärke für die Phasenumschaltung angepasst als auch das Ladelimit von 85 auf 100% angehoben. Beides hatte keinen Effekt. Ich konnte in loadvars entdecken dass die Konfiguration nun aus dem Broker gelesen wird, hier war in der Tat noch das alte Limit (85%) enthalten, obwohl die Einstellungen in der UI auf 100% standen. Hatte vorher schon den Wert verändert, gespeichert, wieder auf 100% gesetzt - leider ohne Erfolg.

Hab' mit MQTTExplorere den Wert 'config/set/pv/lp/1/socLimitation' auf 100 gesetzt und wurde der LP entsperrt und die Ladung hat begonnen. Werden die Änderungen aus der UI ggf. nicht dorthin geschrieben?

[Update]
Hab' jetzt mal ein wenig gesucht und bin zu folgendem Schluss gekommen:
Auto ist inzwischen auf 100% aufgeladen, in dein Einstellungen das SoC Limit für PV Laden wieder auf 85 konfiguriert und gespeichert. Ladepunkt bleibt aktiv.
Wenn ich das richtig beobachtet habe setzt der Regler in den Einstellungen das Topic 'maxSocToChargeTo' wohingegen die Regelung auf 'maxSoc' über die Variable stopchargepvpercentagelp1 zurückgreift.
Das topic maxSocToChargeTo wird in loadvars zwar einer Variable zugewiesen, VSCode hat aber keine Treffer in den Regelscripten angezeigt. Kann das so sein oder habe ich schlicht etwas übersehen?

Screenshot 2022-05-15 223301.png
Screenshot 2022-05-15 223041.png
Die Konfiguration wird nach wie vor aus der openwb.conf gelesen. Im Broker wird lediglich der Wert nochmal für das UI hinterlegt. Die Einstellungen zu den Lademodi nutzen ausschließlich den Broker und nicht mehr den Weg über PHP und openwb.conf.

Die Einstellung "maxnurpvsoclp1" wird in der "nurpv.sh" Zeile 89 verwendet.
"stopchargepvpercentagelp1" (oder "...lp2") taucht hingegen in "nurpv.sh" sowie "minundpv.sh" auf.

Beide Einstellungen sind auch in der Einstellungsseite vorhanden, schließen sich aber gegenseitig aus. Wenn nur ein Ladepunkt vorhanden ist, wird "maxSocToChargeToLp1" (-> "maxnurpvsoclp1" in der openwb.conf) sichtbar. Wenn mehrere Ladepunkte eingerichtet sind, werden die Topics "maxSoc" der Ladepunkte (-> "stopchargepvpercentagelp1" in der openwb.conf) angezeigt. In den Bereichen wurde schon eine gefühlte Ewigkeit keine Anpassung vorgenommen.

Dementsprechend sieht auch die Behandlung in der "nurpv.sh" aus:

Code: Alles auswählen

	if [[ $lastmanagement == "0" ]]; then
		if [[ $socmodul != "none" ]]; then
			if (( soc < minnurpvsoclp1 )); then
				if grep -q 0 "/var/www/html/openWB/ramdisk/ladestatus"; then
					runs/set-current.sh "$minnurpvsocll" all
					openwbDebugLog "CHARGESTAT" 0 "LP1, Lademodus NurPV. Ladung mit ${minnurpvsocll}A, $soc % SoC noch nicht erreicht"

					openwbDebugLog "MAIN" 1 "Starte PV Laden da $sofortsoclp1 % zu gering"
				else
					if (( llalt != minnurpvsocll )); then
						runs/set-current.sh "$minnurpvsocll" all
						openwbDebugLog "CHARGESTAT" 0 "LP1, Lademodus NurPV. Ladung geändert auf ${minnurpvsocll}A, $soc % SoC noch nicht erreicht"
					fi
				fi
				echo "Ladung mit ${minnurpvsocll}A, da $minnurpvsoclp1 % SoC noch nicht erreicht" > ramdisk/lastregelungaktiv
			exit 0
			fi
			if (( soc > maxnurpvsoclp1 )); then
				if grep -q 1 "/var/www/html/openWB/ramdisk/ladestatus"; then
					runs/set-current.sh 0 all
					openwbDebugLog "CHARGESTAT" 0 "LP1, Lademodus NurPV. Ladung gestoppt, $soc % SoC erreicht"
					openwbDebugLog "MAIN" 1 "Beende PV Laden da $sofortsoclp1 % erreicht"
				fi
			exit 0
			fi
		fi
	fi
"maxnurpvsoclp1" wir in einem Block verwendet, der nur bei einem Ladepunkt ausgeführt wird ($lastmanagement == "0").
"stopchargepvpercentagelp1" (oder "...lp2") wird genutzt, wenn "Sperren nach Abstecken" der Ladepunkte deaktiviert ist.

Das ist definitiv nicht alles sauber gelöst und die ganzen Abhängigkeiten lassen einem graue Haare wachsen. Das wird aber definitiv in 1.9 nicht mehr angepasst. Genau für sowa ist ja die 2.0 mit einer strukturierten Codebasis da.
Ja, ist irgendwie reichlich komplex, da stimme ich voll und ganz zu.
Bei mir war es definitiv so dass die Absenkung de SoC Limits im PV Betrieb von 100 auf 85% erst aktiv wurde nachdem ich den Wert im Broker gesetzt habe. Sekunden später war der Ladepunkt wie erwartet deaktiviert.

Womöglich Laufe ich hier allerdings noch in andere Themen rein, ich hatte mal zwei Ladepunkte mit Lastmanagement, habe dann aber einen Ladepunkt aus der 1.9er entfernt. Womöglich ist Lastmanagement in der Konfig jetzt noch aktiv, wenngleich mir die UI Elemente mangels weiterem Ladepunkt nicht mehr angezeigt werden.
4kWp + 3,6kWp SMA PV + EnergyMeter, openWB Standard+, openWB custom als zweiter externer Ladepunkt, Peugeot e2008, Tesla Model Y LR, openWB custom inzwischen über openWB 2.0 gesteuert.
Antworten