openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Fragen zur Nutzung, Features, usw..
Antworten
thesorrow101
Beiträge: 355
Registriert: Mo Okt 12, 2020 7:41 am

openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von thesorrow101 »

Hallo ihr,

ich bin am Ende mit meinem Latein. Letztens hat noch alles geklappt, seit einem Update (ich weiß nicht welches von den letzten 3) geht nichts mehr.

Wenn ich mein Auto anschließe, dann werden sofort 8kW durchgeschliffen, egal auf was für einem Lademodus die openWB steht. Ich kann den Modus ändern wie ich lustig bin, das ändert überhaupt nichts (siehe Bild).
Unbenannt.jpg
Wie gesagt, die Box steht auf Stop, ich schließe das Auto an und zack wird geladen, obwohl nichts freigegeben sein dürfte.
Auch erkennt die Box das ganze nicht mehr als Ladung, sondern als Hausverbrauch.

Entsprechend ist es auch egal welchen Modus ich auswähle, es ändert sich nichts, auch im Sofortladen nicht.

Update auf die neueste Nightly heute früh erfolgt, auch Reboot (über Einstellungen) ohne Erfolg...

Weiß einer kurzfristig Rat? Sonst mach ich ein Ticket auf

Edit: Scheinbar geht der EVSE CP nicht
2021-10-14 12:53:52: Modbus EVSE read CP1 issue - using previous state
LutzB
Beiträge: 1349
Registriert: Di Feb 25, 2020 9:23 am

Re: openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von LutzB »

Sieht so aus, als ob die Modbuskommunikation mit der EVSE und dem Zähler nicht funktioniert. Vielleicht etwas in der Modulkonfiguration der Ladepunkte verstellt?
thesorrow101
Beiträge: 355
Registriert: Mo Okt 12, 2020 7:41 am

Re: openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von thesorrow101 »

LutzB hat geschrieben: Do Okt 14, 2021 11:53 am Sieht so aus, als ob die Modbuskommunikation mit der EVSE und dem Zähler nicht funktioniert. Vielleicht etwas in der Modulkonfiguration der Ladepunkte verstellt?
Woran erkenne ich ob ich Zähler Variante 1 oder Variante 2 habe?
thesorrow101
Beiträge: 355
Registriert: Mo Okt 12, 2020 7:41 am

Re: openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von thesorrow101 »

Oder soll ich einfach mal openWB Deamon auswählen?
HSC
Beiträge: 2349
Registriert: So Jan 10, 2021 8:49 am

Re: openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von HSC »

Ich würde die Autoerkennung versuchen (betrifft den Zähler).
VG
thesorrow101
Beiträge: 355
Registriert: Mo Okt 12, 2020 7:41 am

Re: openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von thesorrow101 »

HSC hat geschrieben: Do Okt 14, 2021 1:59 pm Ich würde die Autoerkennung versuchen (betrifft den Zähler).
VG
Leider auch nicht

Code: Alles auswählen

loadvars.sh: Zeile 88: [: : Ganzzahliger Ausdruck erwartet.
2021-10-14 17:30:13: Modbus EVSE read CP1 issue - using previous state '' (LV0)
loadvars.sh: Zeile 82: /var/www/html/openWB/ramdisk/evseplugstate: Datei oder Verzeichnis nicht gefunden
loadvars.sh: Zeile 88: [: : Ganzzahliger Ausdruck erwartet.
2021-10-14 17:30:03: Modbus EVSE read CP1 issue - using previous state '' (LV0)
loadvars.sh: Zeile 82: /var/www/html/openWB/ramdisk/evseplugstate: Datei oder Verzeichnis nicht gefunden
2021-10-14 17:30:03: ##### cron5min.sh finished ##### (LV0)
2021-10-14 17:30:02:  Load: 1.23 1.87 1.65
2021-10-14 17:30:01: ##### cron5min.sh started ##### (LV0)
AttributeError: 'NoneType' object has no attribute 'interCharTimeout'
    self.socket.interCharTimeout = self.inter_char_timeout
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/sync.py", line 476, in connect
    if not self.connect():
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/sync.py", line 106, in execute
    return self.execute(request)
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/common.py", line 125, in read_input_registers
    resp = client.read_input_registers(0x00,2, unit=sdmid)
  File "/var/www/html/openWB/modules/mpm3pmll/readmpm3pm.py", line 93, in <module>
Traceback (most recent call last):
loadvars.sh: Zeile 88: [: : Ganzzahliger Ausdruck erwartet.
2021-10-14 17:29:52: Modbus EVSE read CP1 issue - using previous state '' (LV0)
loadvars.sh: Zeile 82: /var/www/html/openWB/ramdisk/evseplugstate: Datei oder Verzeichnis nicht gefunden
AttributeError: 'NoneType' object has no attribute 'interCharTimeout'
    self.socket.interCharTimeout = self.inter_char_timeout
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/sync.py", line 476, in connect
    if not self.connect():
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/sync.py", line 106, in execute
    return self.execute(request)
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/common.py", line 114, in read_holding_registers
    request = client.read_holding_registers(readreg,reganzahl,unit=modbusid)
  File "runs/readmodbus.py", line 17, in <module>
Traceback (most recent call last):
AttributeError: 'NoneType' object has no attribute 'interCharTimeout'
    self.socket.interCharTimeout = self.inter_char_timeout
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/sync.py", line 476, in connect
    if not self.connect():
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/sync.py", line 106, in execute
    return self.execute(request)
  File "/usr/local/lib/python2.7/dist-packages/pymodbus/client/common.py", line 125, in read_input_registers
    resp = client.read_input_registers(0x00,2, unit=sdmid)
  File "/var/www/html/openWB/modules/mpm3pmll/readmpm3pm.py", line 93, in <module>
Traceback (most recent call last):
loadvars.sh: Zeile 88: [: : Ganzzahliger Ausdruck erwartet.
2021-10-14 17:29:42: Modbus EVSE read CP1 issue - using 
 
HSC
Beiträge: 2349
Registriert: So Jan 10, 2021 8:49 am

Re: openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von HSC »

Hast Du eine ältere oder neuere openWB?
Die Neueren haben für EVSE + Zähler einen USB- Modbus- Adapter verbaut. Der Stecker könnte sich am Raspi ggf. gelockert haben bzw. könnte man diesen auf einen anderen Port stecken.
Bei den Vorgängermodellen wurde der Modbus vom Raspi direkt verwendet. Da gab es häufiger Kommunikationsprobleme.
Ich würde die Box mal öffnen und nachschauen.
Ansonsten kannst Du auch ein Ticket erstellen....
VG
thesorrow101
Beiträge: 355
Registriert: Mo Okt 12, 2020 7:41 am

Re: openWB erkennt Ladung nicht mehr, trotz STOP 8kW Leistung

Beitrag von thesorrow101 »

Ticket ist schon erstellt, ich melde mich dann mit dem Ergebnis. Dir schon mal vielen Dank für die Tips!
Antworten