EVU-Bezug resp. -Einspeisung falsch berechnet?

Fragen zur Nutzung, Features, usw..
Antworten
Dd62
Beiträge: 4
Registriert: Sa Okt 05, 2019 3:19 pm

EVU-Bezug resp. -Einspeisung falsch berechnet?

Beitrag von Dd62 » Sa Okt 05, 2019 4:08 pm

Hallo zusammen

Ich habe meine OpenWB Standalone (1.6 stable) in Betrieb genommen. Mein Ladepunkt ist ein go-e-Charger. "Sofort laden" funktioniert bestens.

Laden mit "Nur PV" funktioniert nicht wie erwartet. Ich vermute, dass die Ursache bei der falschen Berechnung von EVU-Bezug resp. -Einspeisung zu suchen ist.
EVU_falsch_berechnet.jpg
EVU_falsch_berechnet.jpg (86.56 KiB) 885 mal betrachtet
Als EVU-Wert würde ich eine Einspeisung von 398 Watt erwarten. Im obenstehenden Screenshot wird fälschlicherweise der PV-Netto-Ertrag plus der Hausverbrauch aufsummiert und als Bezug ausgewiesen.

Ich habe in der Konfiguration den Hausverbrauch auf den konstanten Wert von 300 W eingestellt. Als PV-Modul habe ich das SMA Energy Meter konfiguriert. Es ist im Hausstromnetz so platziert, dass es Netto-Export oder Netto-Import ausweisen kann. Der OpenWB-PV-Modulwert versteht sich somit als Stromproduktion der PV-Anlage minus der Stromverbrauch des Haushaltes (ohne den go-e-Charger, der vom Elektriker (eventuell fälschlicherweise) zwischen dem EVU-Stromzähler und dem SMA Energy Meter angeschlossen wurde) .
SMAem_mit_Netto_Export.jpg
SMAem_mit_Netto_Export.jpg (37.69 KiB) 885 mal betrachtet
Habe ich eine Chance, das System richtig fertig zu konfigurieren? Kann ich in einer der Dateien ein Berechnungsformel modifizieren? Kann mir bitte jemand die entsprechende Datei samt Pfad nennen? Mir ist bewusst, dass ich sie nach jedem OpenWB-Update jeweils wieder händisch anpassen muss.

Schema der Platzierung des SMA-Energy Meter und der Kabelführung zum Ladepunkt (Wallbox go-e-Charger, 1-phasig):
Anschlussschema_mit_Text.jpg
Anschlussschema_mit_Text.jpg (900.54 KiB) 877 mal betrachtet
Besten Dank für Eure Unterstützung. Die Nennung der betroffenen Datei wird mich davor bewahren, eine aufwändige Suche in den Quelldateien vornehmen zu müssen.
Zuletzt geändert von Dd62 am Sa Okt 05, 2019 6:20 pm, insgesamt 1-mal geändert.

KevinW
Site Admin
Beiträge: 2644
Registriert: So Okt 07, 2018 1:50 pm

Re: EVU-Bezug resp. -Einspeisung falsch berechnet?

Beitrag von KevinW » Sa Okt 05, 2019 5:42 pm

Du solltest das PV Modul auf None stellen.
Im Gegenzug den Energy Meter (nutz das SMA Home Manager Modul) als EVU konfigurieren.
Sofern es wirklich so angeschlossen ist wie in deinem Schema dargestellt.

Der Go-e ist auch auf "höhe" Haushalt angeschlossen, oder?

Dd62
Beiträge: 4
Registriert: Sa Okt 05, 2019 3:19 pm

Re: EVU-Bezug resp. -Einspeisung falsch berechnet?

Beitrag von Dd62 » Sa Okt 05, 2019 6:22 pm

Ich hatte versehentlich das falsche dritte Bild hochgeladen. Ich habe nun die korrekte Version hochgeladen, welche die Einbindung der Wallbox (go-e-Charger) zeigt.

KevinW
Site Admin
Beiträge: 2644
Registriert: So Okt 07, 2018 1:50 pm

Re: EVU-Bezug resp. -Einspeisung falsch berechnet?

Beitrag von KevinW » Sa Okt 05, 2019 6:42 pm

Richtige Variante:
go-e hinter den Zahler, Zähler als EVU Modul,
vorteil:
- SMA Portal stimmt
- wenn mal ein Speicher kommt stimmt es

Unschöne Variante:
/var/www/html/openWB/modules/smaemd_pv/main.sh
Zeile 9 hinter das 1000 ein *-1
EVUModul auf None, Hausverbrauch auf 0 (der ist ja schon bei PV mit drin)
Nachteil:
- überlebt kein Update
- logging klappt nicht
- nur ne Vermutung, keine Garantie das es klappt

phaidros
Beiträge: 15
Registriert: Do Nov 07, 2019 3:01 pm

Re: EVU-Bezug resp. -Einspeisung falsch berechnet?

Beitrag von phaidros » Fr Nov 08, 2019 10:59 am

Hallo,

ich denke, ich habe ein ähnliches Problem. Bei mir wird die PV Leistung nicht oder falsch angezeigt.

Bildschirmfoto 2019-11-08 um 11.56.22.png
Bildschirmfoto 2019-11-08 um 11.56.22.png (122.67 KiB) 716 mal betrachtet
Im angehängten Fall wurden von der PV ca 5 kW produziert (2,18+2,72kW), die PV zeigt aber 0 an.

Vielen Dank für einen Hinweis, wie man das beheben kann.

phaidros

KevinW
Site Admin
Beiträge: 2644
Registriert: So Okt 07, 2018 1:50 pm

Re: EVU-Bezug resp. -Einspeisung falsch berechnet?

Beitrag von KevinW » Fr Nov 08, 2019 9:37 pm

Welches PV Modul wird genutzt?

Dd62
Beiträge: 4
Registriert: Sa Okt 05, 2019 3:19 pm

Re: EVU-Bezug resp. -Einspeisung falsch berechnet?

Beitrag von Dd62 » So Jan 05, 2020 8:24 pm

KevinW hat geschrieben:
Sa Okt 05, 2019 6:42 pm
Richtige Variante:
go-e hinter den Zahler, Zähler als EVU Modul,
vorteil:
- SMA Portal stimmt
- wenn mal ein Speicher kommt stimmt es

Unschöne Variante:
/var/www/html/openWB/modules/smaemd_pv/main.sh
Zeile 9 hinter das 1000 ein *-1
EVUModul auf None, Hausverbrauch auf 0 (der ist ja schon bei PV mit drin)
Nachteil:
- überlebt kein Update
- logging klappt nicht
- nur ne Vermutung, keine Garantie das es klappt
Ich habe mich für "Richtige Variante" entschieden. Dazu musste ich in mehreren Schritten vorgehen:
1. Durch den Elektriker den go-e hinter dem SMA Energy Meter versetzen lassen.
2. Beschaffung eines Modbus-fähigen SDM120M [M19] für meinen nicht internetfähigen WR (einphasig). (Diese Beschaffung dauerte lange, da zweimal aus China das falsche Modell geliefert wurde. Das funktionierende Modell ist im beiliegenden Bild abgebildet (ist abweichend von den in den Youtube-Filmchen zu sehenden Modellen).)
SDM120M.JPG
SDM120M.JPG (391.72 KiB) 416 mal betrachtet
3. Verkabelung des SDM120M zum am Raspi PI3 angeschlossenen USB-RS485-Konverter.
4. Installation von https://github.com/gianfrdp/SDM120C auf dem Raspi PI3.
5. Entwicklung eines Perl-Skripts, welches einmal pro Minute mit dem Executable sdm120c von "gianfrdp" vom SDM120M die aktuelle Leistung und die kumulierte Stromerzeugung des WR ausliest und nach /var/www/html/<mein_haus>/ramdisk/pvwatt und/var/www/html/<mein_haus>/ramdisk/pvewh schreibt.
6. Den SMA Energy Meter in OpenWB als EVU-Modul konfiguriert.
7. Als PV-Modul in OpenWB die Option "WR mit URL abfragen" gewählt und die beiden URLs, die zu /var/www/html/<mein_haus>/ramdisk/pvwatt und/var/www/html/<mein_haus>/ramdisk/pvewh führen, konfiguriert.

Nun funktioniert alles wunderbar und korrekt. :-) Herzlichen Dank an alle OpenWB-Entwickler für die grossartige Software!

Antworten