Meine Open WB mit Raspberry ZeroWH

OpenWB nachgebaut?
Bericht über die Umsetzung hier rein!
Antworten
reithie
Beiträge: 3
Registriert: Mi Mai 08, 2019 5:08 pm

Meine Open WB mit Raspberry ZeroWH

Beitrag von reithie »

Hallo, ich möchte von meiner Installation OpenWB für Ladung Renault Zoe berichten.
Grundlage der Installation ist ein Raspberry py ZeroWH. Der Grund ist der geringere Stromverbrauch gegenüber dem 3er. Dieser wird mir auch mit 1 Watt angezeigt.
Der erste Gedanke war nur die Regelung des Fotovoltaik Stroms, um die Anlage mit Eigenverbrauch gut auszulasten. Meine Anlage leistet nur 7,28KWp. Der Zoe könnte also mehr Ladeleistung vertragen.
Da die Stromleitung von der Fotovoltaik durch die Garage läuft, trennte ich diese auf und setzte einen MPM3M dazwischen. Der Raspberry wurde gleich daneben installiert und mittels einem USB/RS485 Modbus verbunden. Die Verbindung zur EVSE WB stellt ein MCP4728 DA- Wandler her. Aufgrund der guten Beschreibung klappte das auch bald, aber es wollte sich keine Regelung einstellen.
Ich merkte dann, nach einigem Probieren, dass man unbedingt einen Baustein für den Ladestrom braucht. Die Anlage wurde um einen SDM120 und sowie einem USB/RS485 Modbus und um einen Hub erweitert, weil der Zero nur einen USB Anschluss hat. Hier hat erst ein aktiver Hub funktioniert. Aber als das funktionierte konnte ich den Strom vom Hub wieder weg nehmen. Seitdem funktioniert er so.

Installiert habe ich die 1.6 Stable. Die werde ich auch belassen, weil diese Version schafft der ZeroWH. Bei einer höheren Version machte er Probleme.
Mit dieser Regelung bin ich zufrieden. Sie funktioniert auch zuverlässig.
Hier kann ich dem OpenWB Team nur meinen Dank und Anerkennung aussprechen. Ich bin Maschinenbauer, also kein Elektriker. Aber mit der guten Beschreibung und etwas Übung am Computer ist das zu schaffen.
Allerdings zeigt er seit Renault die App geändert hat, den SOC nicht mehr an. Kann mir jemand sagen, was ich am Programm ändern muss? Ich möchte die 1.6 Stable belassen.
Viele Grüße Reithie.
okaegi
Beiträge: 650
Registriert: Fr Mär 08, 2019 1:57 pm

Re: Meine Open WB mit Raspberry ZeroWH

Beitrag von okaegi »

Renault hat die Schnittstelle um den Soc für die zoe auszulesen komplett umgestellt (neuer Server) Da brauchst du schon die neuste Openwb Version.
Gruss Oliver
aiole
Beiträge: 2522
Registriert: Mo Okt 08, 2018 4:51 pm

Re: Meine Open WB mit Raspberry ZeroWH

Beitrag von aiole »

Meinst Du wirklich, dass der Stromverbrauch RPi Zero + Hub vs. RPi3 "kriegsentscheidend" ist?
Ich sehe immer zu, dass ich weitgehend die empfohlene HW nutze, um bei upgrades kompatiblel zu bleiben.

Mit der EVSE WB (statt EVSE DIN) dürfte RS485 fehlen, korrekt? Darüber werden allerdings auch Zusatzinfos wie z.B. "Fahrzeug angesteckt" übertragen. Die allerersta DAC-Variante ist zumindest in den Serien-WB ausgestorben.

VG aiole
Antworten