Support: Manuell + Berechnung

Alles rund um SoC (Ladezustand des Fahrzeuges). Probleme, Fragen, Fehlfunktionen gehören hier hin
Rosi23
Beiträge: 22
Registriert: Di Feb 16, 2021 6:18 pm

Re: Support: Manuell + Berechnung

Beitrag von Rosi23 »

philipp123 hat geschrieben: So Feb 20, 2022 11:53 am
Rosi23 hat geschrieben: So Feb 20, 2022 11:26 am
philipp123 hat geschrieben: So Feb 20, 2022 10:02 am Nutzt du die Cloud? Vielleicht kommt dein neues Problem auch daher, dass die Cloud gerade nicht tut und alte Werte erneut liefert.
Nein. Die PV-Daten sowie openwb-Daten laufen über LAN und von fritzbox zu fritzbox über Mesh. Nachdem, was ich probiert habe, übernimmt openwb meine Eingabe nicht. Selbst die Direkt-Eingabe an meiner Box wird nicht übernommen.
Heute Nachmittag muss wieder geladen werden, dann schauen wir halt mal - Selbstheilung?
Ich meinte die offizielle Cloud zum Zugriff von Unterwegs. Hier ein Problem, dass die Box sich selbstständig gemacht hat. viewtopic.php?f=9&t=4840
Jetzt tut sie aber aktuell wieder.
Ich benutze die offizielle Cloud nicht. Nur per http://192.168.178.99/openWB/web/index.php am PC oder Tablet (was ständig im Flur läuft).
openWB series2 standard+, SolarEdge SE10K-N4, PV 9,60 kWp. :arrow: go-eCharger, Nissan Leaf ZE01, Kie e-Niro, Kia EV6
Rosi23
Beiträge: 22
Registriert: Di Feb 16, 2021 6:18 pm

Re: Support: Manuell + Berechnung

Beitrag von Rosi23 »

Der Support hat sich bei mir gemeldet. "Guten Morgen, da es am Wochenende Probleme mit der Cloud gab, besteht das Problem aktuell noch?".
Ich schrieb: Seit Sonntag 16:30Uhr funktioniert es wieder und ich gebe die Daten am Display ein. Ich benutze keine Cloud. Antwort: "Hallo, ggf. wurden hier Daten übernommen / zurückgesetzt." Da werden wohl die SoC Eingaben doch irgendwie in der Cloud benutzt??? Keinen Plan.
openWB series2 standard+, SolarEdge SE10K-N4, PV 9,60 kWp. :arrow: go-eCharger, Nissan Leaf ZE01, Kie e-Niro, Kia EV6
rirama
Beiträge: 21
Registriert: Sa Aug 21, 2021 7:57 am

Re: Support: Manuell + Berechnung

Beitrag von rirama »

Moin,

bei mir funktionierte die Manuelle Berechnung überhaupt nicht. Der SoC wird aus mypsa ausgelsen, aber es finden während des Ladens keine Veränderungen statt, ausser ich aktualiesiere meine myopel app. Dann wird der neue SoC von dort übertragen.

Im Log wird alle paar Sekunden angeblich das Laden neu gestartet, obwohl an sich alles wie ein ganz normaler LAdevorgang ohne Unterbrechungen läuft.

Kernel: Linux 4.19.66-v7+ GNU/Linux
Python 3.5.3
openWB Version: 1.9.265
Dateianhänge
OWB Einstellungen 3.jpg
LutzB
Beiträge: 2374
Registriert: Di Feb 25, 2020 9:23 am

Re: Support: Manuell + Berechnung

Beitrag von LutzB »

Hier geht es um das eigenständige Modul "Manuell + Berechnung". Du nutzt anscheinend das PSA Modul mit aktivierter Option zur manuellen Berechnung während des Ladevorgangs. Das sind zwei komplett verschiedene Module.

Für das PSA Modul gibt es noch keinen offiziellen Support-Beitrag, daher einfach einen neuen Beitrag im Unterforum SoC erstellen.
zut
Beiträge: 87
Registriert: Di Feb 23, 2021 9:34 pm

Re: Support: Manuell + Berechnung

Beitrag von zut »

Heute morgen 3:33 Uhr trat bei mir das Phänomen auf, daß der SOC des angeschlossenen Fahrzeugs wieder auf 38%, den manuell eingegebenen Wert von vor dem Laden gestern abend sprang und von dort aus wieder bis auf den Ziel-SOC hochlud. Der echte SOC des Fahrzeugs ist jetzt natürlich deutlich höher als die gewünschten 60%.

Meine Daten:

Software:
Kernel: Linux 4.14.71-v7+ GNU/Linux
Python 3.5.3
openWB Version: 1.9.275

Ladestatus Änderungen:
2022-09-08 05:07:52: PID: 22278: LP1, Ladung gestoppt (LV0)
2022-09-08 05:06:46: PID: 12974: LP1, Lademodus Sofort. Ladung gestoppt, 60 % SoC erreicht (LV0)
2022-09-08 03:33:52: PID: 6285: LP1, Ladung gestartet (LV0)
2022-09-08 03:33:46: PID: 4887: LP1, Lademodus Sofort. Ladung geändert auf 13 Ampere, Lastmanagement aktiv (LV0)
2022-09-07 20:49:52: PID: 5294: LP1, Ladung gestoppt (LV0)
2022-09-07 20:48:46: PID: 28278: LP1, Lademodus Sofort. Ladung gestoppt, 60 % SoC erreicht (LV0)
2022-09-07 19:14:42: PID: 9741: LP1, Ladung gestartet (LV0)
2022-09-07 19:14:36: PID: 8341: LP1, Lademodus Sofort. Ladung geändert auf 13 Ampere, Lastmanagement aktiv (LV0)
2022-09-07 19:14:26: PID: 6995: LP1, Lademodus Sofort. Ladung geändert auf 6 Ampere (LV0)
2022-09-07 19:14:16: PID: 5654: LP1, Lademodus Sofort. Ladung geändert auf 6 Ampere (LV0)
2022-09-07 19:14:06: PID: 4258: LP1, Lademodus Sofort. Ladung geändert auf 6 Ampere (LV0)
2022-09-07 19:13:58: PID: 2930: LP1, Lademodus Sofort. Ladung geändert auf 6 Ampere (LV0)
2022-09-07 07:46:41: PID: 9881: LP1, Ladung gestoppt (LV0)
2022-09-07 06:20:22: PID: 20870: LP1, Ladung gestartet (LV0)
"EV SoC Log" und "Nur Ladepunkt Log" sind leer ("Reboot")

Graph von heute morgen:
Bildschirmfoto vom 2022-09-08 08-06-12.png
Mir scheint, es gibt einen Phantomspeicher, in dem der eingegebene Ladestand weiter vorhanden ist? Ich habe den Thread bisher nur überflogen, aber mir scheint, es gibt ähnlich Effekte bei anderen?

Vermutlich nicht in Beziehung dazu ist, daß ich gestern früh Zielladen aktiv hatte, was auch funktionierte wie erwünscht.
M_aus_BW
Beiträge: 46
Registriert: Sa Okt 24, 2020 9:30 pm

Re: Support: Manuell + Berechnung

Beitrag von M_aus_BW »

Seit ein paar Wochen stelle ich ein ähnliches Verhalten fest.
Ich habe das PSA SoC-Modul mit manueller Berechnung eingestellt. Das funktioniert recht genau.
Gelegentlich kann es sein, dass zwischen openWB und meinem Peugeot z.B. ein Prozent Differenz entsteht. Wenn die Box die Ladung wegen Erreichen des eingestellten SoC beendet hat, kommt es offensichtlich noch einmal zu einem Datenaustausch mit dem Auto. Etwa 5 - 10 Minuten später wird der Rest nachgeladen, bis auch der Peugeot den vorgegebenen SoC erreicht hat.

Zur Info.
Nach erneuter Reklamation bei Peugeot, erhielt ich folgende Antwort:

"Es tut uns leid Ihnen mitzuteilen, dass es derzeit mit der aktuellen Version unserer myPeugeot-App noch einige technische Probleme gibt. Unsere Fachabteilung arbeitet bereits unter Hochdruck an einer Lösung. Da es sich um einen technisch komplexen Sachverhalt handelt, nimmt die Problembehebung mehr Zeit in Anspruch und soll mit dem nächsten Update behoben werden. Selbstverständlich sind wir laufend um Innovationen und Verbesserungen bemüht."
zut
Beiträge: 87
Registriert: Di Feb 23, 2021 9:34 pm

Re: Support: Manuell + Berechnung

Beitrag von zut »

Möglicherweise hängt das Problem mit den SOC bei mir doch am Zielladen: heute früh wieder um 3:33 ist der SOC nach dem Zielladen wieder auf dem Wert vor dem Zielladen heruntergefallen.
zut
Beiträge: 87
Registriert: Di Feb 23, 2021 9:34 pm

Re: Support: Manuell + Berechnung

Beitrag von zut »

Nein, auch ohne Zielladen wird der SOC nachts zurück gesetzt auf den Wert vor Ladestart.
Screenshot_20220917-095207.png
Höchstens, dass nach deaktivierem Zielladen noch Funktionsteile aktiv sind, die den SOC beschreiben?
zut
Beiträge: 87
Registriert: Di Feb 23, 2021 9:34 pm

Re: Support: Manuell + Berechnung

Beitrag von zut »

Und wieder wieder heute Nacht gegen 03:47 der SOC sprunghaft nach unten korrigiert, diesmal ohne Auto daran.
zut
Beiträge: 87
Registriert: Di Feb 23, 2021 9:34 pm

Re: Support: Manuell + Berechnung

Beitrag von zut »

Nachdem ich grob über den Code (stable 1.9.275) geschaut habe, gehe ich davon aus, daß gegen 03:47Uhr einmal kurz das Modul soc_manual.py aufgerufen wird und der Wert der Variable manual_soc_lp1 plus der Effekt von 0kWh auf soc kopiert wird, da in der kurzen Zeit nichts geladen wird.

Frage ist, warum das Modul nachts aufgerufen wird. In den /etc/cron* habe ich nichts dazu gefunden.
Antworten