Support: Mercedes EQ

Alles rund um SoC (Ladezustand des Fahrzeuges). Probleme, Fragen, Fehlfunktionen gehören hier hin
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

JA, das kann auch immer wieder mal sein. Die Meisten hatten dann einen Return Code 204, dass das Fahrzeug keine Daten hat.
Hast du die Drittanbieter Dienste erst heute aktiviert?

VG
Det
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
Benutzeravatar
ragsna
Beiträge: 123
Registriert: Mi Nov 04, 2020 5:00 pm

Re: Support: Mercedes EQ

Beitrag von ragsna »

Ich habe heute bemerkt, dass die SOC Abfrage nicht mehr funktioniert.

Folgendes Log:
2021-09-24 11:59:08: Lp1: PID:8320: {"exVeErrorId":"2","exVeErrorMsg":"Account Country Code null or empty.","exVeErrorRef":"e077ebcc-b618-4590-8ff6-1a55096b018b"}
2021-09-24 11:59:08: Lp1: PID:8320: SoC Request fehlgeschlagen Code: 403 (Forbidden)
2021-09-24 11:59:08: Lp1: PID:8320: SOC Response: {"exVeErrorId":"2","exVeErrorMsg":"Account Country Code null or empty.","exVeErrorRef":"e077ebcc-b618-4590-8ff6-1a55096b018b"}
2021-09-24 11:59:08: Lp1: PID:8320: SOC Request: 403
2021-09-24 11:59:08: Lp1: PID:8320: client: XXX
2021-09-24 11:59:08: Lp1: PID:8320: Debug Level: 1

Die "Account Country Code" Meldung kommt mir etwas komisch vor. Gab's da irgendwelche Änderungen oder Anpassungen die ich machen muss?
openWB series2 custom - SolarEdge | 9.92 kWp | 2 x SE5000H | LG Resu10H 9.3 kWh - MB EQA 250
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

Hallo,

Kommt bei mir auch gerade. Ich habe nichts in der Richtung mit bekommen, dass sich was geändert hat.
Ich komme vermutlich auch heute nicht mehr dazu was zu schauen. Bin übers WE weg.

Mal sehen, ob es sich wieder beruhigt. 403 Meldungen hatten wir immer wieder mal.

VG
Det
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

Ich habe eine Meldung im Mercedes Developer Portal auf gemacht.

Mal sehen, was passiert.

VG
Det
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
Benutzeravatar
ragsna
Beiträge: 123
Registriert: Mi Nov 04, 2020 5:00 pm

Re: Support: Mercedes EQ

Beitrag von ragsna »

OK, dann bin ich nicht alleine damit :o
Danke für deine Rückmeldung!
VG
openWB series2 custom - SolarEdge | 9.92 kWp | 2 x SE5000H | LG Resu10H 9.3 kWh - MB EQA 250
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

👍🏻
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
Benutzeravatar
ragsna
Beiträge: 123
Registriert: Mi Nov 04, 2020 5:00 pm

Re: Support: Mercedes EQ

Beitrag von ragsna »

SOC Abfrage funktioniert seit 01:00 wieder :)
openWB series2 custom - SolarEdge | 9.92 kWp | 2 x SE5000H | LG Resu10H 9.3 kWh - MB EQA 250
derNeueDet
Beiträge: 2459
Registriert: Mi Nov 11, 2020 7:16 pm

Re: Support: Mercedes EQ

Beitrag von derNeueDet »

👍🏻
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
CLu
Beiträge: 3
Registriert: Do Okt 21, 2021 6:45 am

Re: Support: Mercedes EQ

Beitrag von CLu »

Hallo in die Runde,
ich habe leider etwas Schwierigkeiten die SoC-Abfrage beim EQA ans laufen zu bekommen.
Alle Schritte (MB Developers, etc.) gem. Anleitung erfolgreich durchgeführt bis zu dem Punkt "HIER bei Mercedes Me anmelden". Danach kann ich mich noch bei id.mercedes-benz.com erfolgreich anmelden und es wird zur Seite http://xxx/openWB/modules/soc_eq/callba ... &state=lp1 weitergeleitet. Hier sehe ich aber nur ein leeres Fenster, keine Bestätigung oder Fehler, nur leer.

Diensteaktivierung bei Mme und Redirect-URLs habe ich mehrfach überprüft.

Im openWB-Status sehe ich beim Ladepunkt die "Störungsbeschreibung Code: 1"
Im Log findet sich regelmäßig:
2021-10-21 08:49:34: Lp1: Py Return: 1 (LV1) at 91 main modules/soc_eq/main.sh
ImportError: No module named 'requests'
import os, requests, json, time, sys, os
File "/var/www/html/openWB/modules/soc_eq/soc.py", line 3, in <module>

Und jetzt weiss ich nicht mehr weiter....und hoffe auf Hilfe von einem Experten.
Vielen Dank im Voraus
Chris
LutzB
Beiträge: 2021
Registriert: Di Feb 25, 2020 9:23 am

Re: Support: Mercedes EQ

Beitrag von LutzB »

Hast Du openWB selbst installiert? Da fehlt das Python Modul "requests".

[EDIT]
In der aktuellen Nightly wird das Modul jetzt geprüft und eventuell nachinstalliert.
Antworten