seltsame DNS-Abfragen

Hier kommt alles rein was nicht direkt zur OpenWB gehört.
Antworten
Glotzkowski
Beiträge: 1
Registriert: Di Sep 21, 2021 11:21 am

seltsame DNS-Abfragen

Beitrag von Glotzkowski »

Bei Tests und Analyse der Kommunikationsverbindungen der openWB (funktioniert alles ohne Probleme) ist mir heute aufgefallen, dass es ca. fünfminütlich zu seltsamen DNS-Abfragen des Gerätes kommt.

Dabei versucht die openWB Hostnamen (also keine FQDN) bestehend aus zufälligen Buchstabenkombinationen aufzulösen.
Version 1.9.244

Das habe ich per Wireshark aufgezeichnet und kann es auch in meinem DNS-Server sehen.
Die Anfragen können natürlich nicht aufgelöst werden, konnte dies auch bereits jemand beobachten und weiß jemand was das sein soll?

Ähnliches Verhalten kenne ich nur von Systemen, welche mit Malware oder ähnlichem bestückt sind und das hoffe und glaube ich in diesem Fall nicht.
Die Box hängt nicht direkt im Internet bzw. ist nicht aus dem Internet erreichbar.
Im Screenshot sieht man auch reguläre DNS-Anfragen, welche korrekt beantwortet werden.
192.168.100.233 ist die openWB
192.168.0.10 ist der DNS-Server
Dass beide Systeme in unterschiedlichen IP-Netzen angeschlossen sind ist korrekt.
openwb-dns-queries.PNG
FosCo
Beiträge: 132
Registriert: Di Jun 30, 2020 9:26 am

Re: seltsame DNS-Abfragen

Beitrag von FosCo »

tatsächlich ja, siehe Anhang.
Dateianhänge
Screenshot 2021-09-21 173453.png
17kWp Ost/Süd/West, 2x Commetering (Discovergy) Smartmeter, FHEM, ID3 Pure (2-phasig 7kW AC), 2x openWB series 2 custom mit RFID
openWB
Site Admin
Beiträge: 6330
Registriert: So Okt 07, 2018 1:50 pm

Re: seltsame DNS-Abfragen

Beitrag von openWB »

Diese werden vom internen Chromium verursacht.
Es versucht dadurch zu erkennen wo es sich befindet und wie sich der ISP verhält
Google spuckt da mehr Infos zu aus wenn gewünscht.
Supportanfragen bitte NICHT per PN stellen.
Hardwareprobleme bitte über die Funktion Debug Daten senden mitteilen oder per Mail an support@openwb.de
derNeueDet
Beiträge: 1465
Registriert: Mi Nov 11, 2020 7:16 pm

Re: seltsame DNS-Abfragen

Beitrag von derNeueDet »

10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
FosCo
Beiträge: 132
Registriert: Di Jun 30, 2020 9:26 am

Re: seltsame DNS-Abfragen

Beitrag von FosCo »

openWB hat geschrieben: Di Sep 21, 2021 3:44 pm Diese werden vom internen Chromium verursacht.
Es versucht dadurch zu erkennen wo es sich befindet und wie sich der ISP verhält
Google spuckt da mehr Infos zu aus wenn gewünscht.
Danke!
Gibt es einen Grund dafür, dass chromium überhaupt drauf ist?
Hätte ich nun einfach nicht erwartet.

Aber danke auch an det, das erklärt ein paar pi.hole Einträge, auch von anderen Geräten 😎
17kWp Ost/Süd/West, 2x Commetering (Discovergy) Smartmeter, FHEM, ID3 Pure (2-phasig 7kW AC), 2x openWB series 2 custom mit RFID
derNeueDet
Beiträge: 1465
Registriert: Mi Nov 11, 2020 7:16 pm

Re: seltsame DNS-Abfragen

Beitrag von derNeueDet »

Das Display ist ein Browser imm Kiosk Mode und der läuft wohl unter Chromium.

VG
Det
10kWp PV mit SMA Tripower 10000TL-10. OpenWB Standard+. EVU/PV über Volkszähler in den JSON Modulen. PHEV Mercedes GLA250e
FosCo
Beiträge: 132
Registriert: Di Jun 30, 2020 9:26 am

Re: seltsame DNS-Abfragen

Beitrag von FosCo »

Danke!
17kWp Ost/Süd/West, 2x Commetering (Discovergy) Smartmeter, FHEM, ID3 Pure (2-phasig 7kW AC), 2x openWB series 2 custom mit RFID
Antworten